Thermostat Humidity Control & Heat Stage 2 Issues

Furnace is working as expected after new thermostat install, but not the whole home humidifier (Aprilaire 560). My humidifier was controlled by 2 wires (red / white) at the prior thermostat (internal humidistat control). Per the Wyze app installation, I attached the red to asterisk but that wire wasn’t recognized and humidifier solenoid didn’t activate as expected. I attached the white wire from solenoid to 24V “c” terminal on furnace (Lennox EL296UHV) to simplify wiring (not go thru transformer). This activates the solenoid and thermostat recognized the red wire, but the thermostat humidity preference settings don’t seem to control solenoid as expected. Alway active or on (water flowing). I can run red wire thru “HUM” terminals on furnace and this deactivates solenoid when heat isn’t called, but still no humidity settings on thermostat control solenoid when heat is called (always on). Also clipped W914 per furnace install instructions, still always on when heat is called. How can I confirm the thermostat humidity settings work? Or how is the asterisk wire supposed to activate/deactivate the solenoid? Is it a switch? Or send sensor info? Any ideas would be appreciated. Thx!

OK so after a service visit this morning, I confirmed a few things. First, Wyze wiring and my modifications are fine. Second, the asterisk wire is energized (or switch is closed 100% of the time) causing the humidifier to run all the time regardless of humidity preference setting. The app setup identifies the asterisk wire as humidity per wiring step therefore I assume that when humidity is above the min setting, it should not call for humidity, but it is. Does anyone know if there is a step or setting I am missing? Third, the W2/H2 is an independent call to the furnace which my furnace isn’t responding to. Confirmed this with test feature in app. The furnace needs both W1 and W2 energized for the furnace to move to H2. So I never achieve H2 heat level. Is anyone else experiencing this? The service tech said most thermostats will maintain W1 call when calling for W2. For now, we switched the furnace to single stage thermostat and will let the furnace control H2. This is an issue that needs to get fixed by Wyze. If in the testing sequence, the user says No to H2 step, it should activate both W1/2 terminals and check for heat, then save that to the profile if yes. I do have a second Wyze thermostat that I could test and see if acts similar, but my patience is wearing thin, and I feel like I am writing a blog…cheers!


Step 3. Spoke to a very pleasant Wyze customer service rep who was quick to say that she could not answer my questions (which I appreciated), and that I would need to work with my local HVAC company. Since I had already done that she asked me to share my wiring pics, describe my issues, and she would forward to level 2. Here’s hoping!

Oh yeah, and I took the opportunity to ask level 2 about temperature differential…what is default, is there a setting, and whether it changes in Behavior settings…

1 Like

@Mark5, I have this same furnace and am hoping it will do exactly what you are mentioning for humidity control. I will be watching this topic.

Thanks Great!


Yesterday after submitting a ticket 3 weeks ago through call-in support (and providing email description with pics), I received the standard automatic response to check compatibility checker and watch install videos. Not sure what took so long for an auto response.

I was pleasant and replied that I had tried that, and it didn’t solve my issue.

Then today, I received a personal response from the original call-in support person that she had head back from the internal team …

“The option is temporarily hidden in the app due to a bug, but we will open it to users in the 2.17+ app version."

Not sure which issue that pertains to, but we know that temp differential is hidden, so that may be what they are referring to. Hopefully, it’s all three issues I have.

Thought I’d share. Keeping the faith, for now.

1 Like

Quick update.

The temperature dropped to the teens, and we woke up with condensation on the windows since the humidifier runs 100% of the time and isn’t controlled by humidity set point. It’s not a good look and will damage the wood window frames.

So, I disconnected the asterisk wire at tstat to stop the humidifier from running. I guess I’ll connect/disconnect depending on the temp.

Wyze please make incremental changes. You don’t have to solve everything. Smaller more frequency firmware will make us happier and show progress toward solving our issues.



1 Like

Just to report back, IT’S WORKING!

Pulled the asterisk wire (intended to control humidity level, and doesn’t - runs 100% of the time) … and woke up with no condensation on the windows with the humidity level at a comfortable 34% … :wink:

We need smaller, more frequent firmware updates!

Just to confirm how to do, reference pics …

I’m in the same boat. The humidifier control doesn’t seem to do anything at all and is powered all of the time (even when the furnace isn’t running). During the setup process (re-setup, I suppose), when it tested the AC, the solenoid did close. So it’s at least capable of deactivating the * terminal, it just seems to be programmed incorrectly and never does.

I sure wish there was some indication of when they plan to release a firmware update that fixes this broken feature. Otherwise, I guess I need to wire up the manual humidistat that came with the humidifier or Wyze is going to let my water trickle down the drain 24/7!

Beta iOS 2.17.21 just came out and now has humidifier control. During setup it asked for type of humidifier (see pic) and now come on when heat is called and below set point. Nice! Strangely, it activates when 5% below set point and then off when 5% above. Oh well, evidence of progress! @WyzeChuan … but no evidence of Stage 2 fix (activate both W1 and W2 on gas forced air heat call)

I have the same issue where I have a separate set of 1 red and 1 white wire. When setting up the thermostat, which letters do I tell the app I have?
I have the normal 5 (C, W, R, Y, G). Do I choose Hum and ?

Thanks for your help!
I’m using 2.17 (not the beta)

Do you have a bypass humidifier or powered? I have bypass and used red at tstat (told it HUM). And at furnace, you need to take the white from the humidifier and attach to C on furnace control board to complete the circuit. If you had a 24V transformer in humidifier wire loop, it won’t be used, and you will now have an unused white wire to tstat. That’s for bypass, not 100% if same for powered humidifier. Good luck!

I have a Bypass. It appears the red humidifier wire is tied in with the R or the C on the control board.
There is a patch wire between the switch in the living room and the furnace so I’m not entirely sure which way it’s wired without testing it.
There is also an electronic relay on a wire leading to the blower that must sense when the blower is on and connect the power to the motor in the humidifier?
So only one wire is needed up to the thermostat and the other can just go straight to C terminal? Is that correct?

Yes. Trace a wire directly from humidifier solenoid to tstat, and the other from solenoid to C. That should do it. Now, depending which app version you’re using it may run all the time (which isn’t good) or turn on/off with heat or fan depending on what you select in setup. I am using iOS 2.17.21 (beta) and it’s working well. Prior to this app version, it was on all the time, but luckily I had 2 HUM terminals on furnace board which I ran thru and it only activated when heat was called not 100% of time. Hope this helps.

What does humidity control look like in the app for you? My HVAC tech told me he wired the humidifier (bypass) to the thermostat, but I don’t see any settings in the app where I can control humidity.

In Settings, there is a Humidity Preference selection below Temperature Preferences (see pic). I do notice that it “appears” a moment after I go to settings. I suspect it is flagged to appear if during setup you indicate that you have a HUM wire that gets connected to asterisk. After 2.17.21 iOS app became avail last week, I would re-setup the thermostat (reset hardware, delete device in app) because there is now more functionality for humidifier in app setup steps.

Reset and device delete worked! Thanks!

1 Like

Does anyone know if we have Stage 2 gas heat working yet? Doesn’t appear to be in 1.1.6.

1 Like