Thermostat Dead on installation

Installed thermostat per instructions. No “Wyze” on thermostat display. Powered down HVAC and double checked all wiring, confirmed it was correct. Still no “Wyze” on thermostat display. I think it’s a DOA unit

It’s possible. One suggestion though. There have been several people (including me) with that problem during setup and it was that the RH wire from my furnace needed to go to the RC connection on the Wyze thermostat.
One troubleshooting step if you have a multimeter is to check for 24 volts AC on the RC and C pins at the thermostat.

There is no “RC” pin or wire on my furnace.

post wiring pix for both tstat & control board…hard to help troubleshoot if we can’t see what u did. many here thought they wired correctly only to find out they did not.

move your Rh at Wyze to Rc.

did u install the c wire adapter? have a pic of the wired wyze tstat?

The wiring at the Wyze thermostat should look like this after installing the C wire adapter

Interesting. YOu have the the G wire connected to the C connector. Is that a mis-label?

No, when you use the C wire adapter, you have to connect the G wire to the C terminal on the Wyze thermostat, it actually tells you to label the G wire as C during installation but it’s easy to miss. Not doing this will result in no power to the thermostat. I know cuz I did it myself, I just left the G label on it.

1 Like

Thanks, I will try this tomorrow.

Good luck, hope you get it working. The bottom line is that in order for the Wyze thermostat to power up, it just requires 24 volts on the RC and C pins and it should boot up. The rest of the connections depend on the type of system. Mine is heat only, no AC, so it works with just RC, C, and W connected I have G connected as an option to be able to run my fan only independent of heat to circulate air, but on my furnace, it would run without G.

Several years ago, my furnace only used two wires, red and white and had a mercury thermostat, but I added the rest of the wires to use a programable thermostat some time ago.

raym64, question for you I have a heat only system as well - I only have 3 wires at furnace R, W, C - which I connected at the wyze thermostat to Rc, W1, C. at first it didnt work except for power on, then went back thru install on APP and said I had Rh, W, C and installation completed and passed all testing, but once i exit testing thermostat just displays 32 degrees, i can set a new temp but it doesn’t do anything. Which wires did you tell the app you had? This should have been easy but maybe i have a bad unit or something - you’re the first person in this forum that I’ve seen has a heat only system, so wondering if there was some trick to this or something.

Not sure if my setup will help because I ended up with mine a bit different than the instructions, mostly because I made a mistake at first. But I’ll tell you everything I did.

Initially, I connected the wires to exactly what they were and like my old programable thermostat which was W to W1, G to G, C to C, and RH to RH. My mistake was connecting RH to RH and the thermostat wouldn’t power up.

I read that RC needed to be connected to power up the thermostat and I rechecked my furnace and saw that I had a “R” wire on my transformer. Since I don’t have AC I had extra wires in my cable, so I connected one to R in the furnace and connected that to RC on the thermostat. Once I did that, it powered up and everything worked.

I did get the error like many others got about missing wires like the Y and W2, etc, but I skipped past that during setup and it works.

I don’t have a control board in my Furnace, most of the wires go to connections on the transformer and the RH and W go to the burner control.

The only note is that like others, have said, when the thermostat calls for heat, it starts the fan right away instead of waiting for the furnace to heat up first which means cold air for a bit. Others have disconnected the G wire to correct that until firmware fixes that. I left mine on because we use a wood pellet stove for much of our heat and one of the reasons I bought the thermostat was to run the fan 10 minutes per hour to move air around.

Here’s a picture of the transformer in my furnace where I got the C, G, and R wires from. This was before I connected a C wire to the bottom left terminal and you can see I connected the blue wire to R which I connected to RC in the thermostat.

:Edited to add: Since I don’t have AC and don’t need a yellow wire, I moved the yellow wire on the transformer over to C and connected that to C at the thermostat.
so overall on mine it’s Furnace C to Thermostat C, R to RC, G to G W to W1, and RH to RH


Thanks for the info, I didnt realize you could get past the no wire connection so told it I had a G wire even though i don’t but that didnt help either except when i tell it to turn on the fan, i hear it actuate the relay and the little fan icon shows, other than that still just sits there with '32" on the screen. I’m thinking I have a bad unit or something at this point. Thanks again.

1 Like

I’ve heard other people say they have 32 on the screen as well, and I’m thinking it is a defective temperature sensor. Try switching it to Celsius and see if that changes anything, otherwise you should probably call support and ask for a RMA.

Thanks Ken, you were correct. I had not noticed that the G wire was suppposed to be re-labeled C. Switching that did the trick. Thank-you!

Thanks for the suggestion but it didn’t work, now it just displays 0.0 . I had already contacted support and they are sending me a replacement, so hopefully the next one works.

Just to update - wyze sent me another thermostat and so far it’s working without issue. Told the app I had R, W, C. Connected to those 3 wires passed all testing and works great.

1 Like