Thermostat connection problem

Super excited just got the wyze thermostat and having issues.

Installed no problem with c adapter. Display worked. Etc.

Went to update and since then it won’t power up.

Does the thermostat have a small battery that allowed the setup and then died (and my wiring was wrong) or did something screw it up during update.

Here’s my wiring setup.

It’s a gas dual stage forced hot air and AC setup.

Old Thermostat had w2, g, w, y, and r/rc jumped.

Control board on furnace had r(red wire), c(white wire), w(white wire), w2(blue wire), g(green wire), and y(with a yellow and red wire together).

Attached the adapter accordingly and triple checked the connection.

Wired the new thermostat like this:

Red to rc
Yellow to y
White to w1
Blue to w2
Green to c

Any help is greatly appreciated!!!

If it was working then died during firmware update then it’s most likely not something you did.

Did you power cycle the thermostat? Personally I’d turn off the breaker shutting off power to the entire system then see if it boots up after turning back on.

I power cycled with the shut-off switches and the breaker as well and tried hosing down the bottom for 30 seconds to try to reset and also did nothing.

Looks like the g isn’t getting any voltage coming out of the c adapter based on my voltage meter.

Check your fuse on your furnace
And show how you wired the C adapter.
It needs to be wired like this
2021-01-02 - 19.46.36 ~ Cropped Capture

Everything looks to be wired correctly. Only difference is thaty y/y2 had both a yellow wire and a red wire attached. I kept it the same for the adapter.

Checked fuse and it was fine.

Put old thermostat back in and it works fine.

That’s your problem.
The only Y wire you want in the wyze adapter Y terminal is the one that goes to your thermostat.
The other red wire goes to your compressor. Put it back on the Y terminal on the furnace board.

I’ll give this a try tomorrow and report back.

The question though is why it started up fine initially, was setup in app fine but lost power and won’t turn on right at/after the firmware update.

I tested the voltage and wasn’t getting anything from the G wire at thermostat…

you might have cooked your adapter, trying to run the compressor off of its tiny relays…