Some videos are sped up/shortened, others are fine

I’m having an issue with my Wyze Cam v3 where some videos (not all), instead of being the normal 1 minute in length, are anywhere from 2s to 45s long with the video sped up (and therefore useless since so many frames are cut) in each of those shorter videos.

I’ve not seen mention of this issue anywhere so I’m not sure what to make of it. I disconnected my camera from power and reconnected it, and let it run for a day and it didn’t seem to have the problem for the day I let it run. But not knowing what caused this or how to prevent it from happening again is bothering me because it might happen when I need the footage the most. I need something reliable.

Attached a screenshot of what my files look like.


Welcome to the Wyze User Community Forum @dannimal! :raising_hand_man:

I would suggest replacing the SD Card with a High Endurance SD Card specifically manufactured for DashCams and Security Cams. My first impression is that you have some bad spots on that card that aren’t accepting the recorded video and the MP4 files are being shortened because of the lack of saved frames.

1 Like

Along with @SlabSlayer recommendation, I’d also say to use rules to schedule in some weekly camera resets at an off hour. I stagger my camera groups and have resets at different times of the morning. I started them long ago to help with audio/video syncing issues and have just kept them and am admittedly probably over vigilant and have scheduled it every night. But it all happens in the background and I don’t even notice. Just another suggestion for you…

I’m already using a Samsung Pro Endurance 256GB card. It’s not even that old, maybe 3 months? This is the first time I’ve noticed an issue. I just checked my other camera and it’s doing the same thing. I have another Samsung Endurance card in it, too. Now that I know it’s happening on both my cameras, I’m even more confused on why this is happening.

I’ll give this a shot. Thanks for the suggestion. I’ll report back whether it worked or not.

1 Like

Probably not the SD then if it is reproduced on multiple cams on new SD Cards.

What firmware version are you running?

Is the video in the app timeline affected when playing thru the minutes affected?

Is there any pattern to the size differences? Does it happen to the same minute files within each hour folder or is it random?

I’m running firmware Yes, the video is affected when playing through the app timeline as well. I don’t see any pattern to the size differences. They don’t happen within the same minute files for each hour; it seems random. The affected videos are usually clumped together… then I’ll get a bunch of full 1 minute videos… then more affected videos… rinse and repeat.

I have a V3 running Beta recording continuous. It was just released today for public release gradual roll out.

I will have to pull the SD tomorrow and inspect to see if it replicates this.

Just pulled the SD Card from my Test Cam running

This is a cheap 32GB Gigastone standard quality SD Card.

All SD MP4 files for the last 24 hours are the appropriate size.

Are you able to modify your file browser view to show the file sizes?

Here’s a new view from yesterday’s files that show the file sizes.

Definately some Freaky Friday stuff going on there. All mine were within the 5 to 8 MB range depending on NV and Motion Tagging.

To isolate if it is a FW issue that was never reported, if you have yet to get the new FW OTA push, I would flash update one of the cams to the newer FW and test it to see.

Ok, I’ll update to the version you have and report back when I can whether it fixed it or not. Thanks for your advice by the way. I’m on the verge of throwing these Wyze in the trash can so I appreciate you trying to help.

I have had most of my 16 V3 cams running for several years now without any major issues. I test all the new Beta Firmware and put my cams thru the paces. There are occasional hiccups with Firmware, but it is rare that I have to flash back to an older version. I wouldn’t give up on them just yet.

I have also encountered the “speed up and shortened” issue, two V2 and one V3, video is down to 2-4 seconds and I am not using any SD cards, just living with the 12 second rule the past 4 years. I did the restart, up to date, checked the cameras and i keep seeing the update to the new full length advertisement - so i assumed its a marketing attempt. will decide before winter on continuation.

Running the latest firmware seems to have made a difference, at least over the past few days. I let it run for 5 days and there don’t seem to be any issues with any of the videos. The camera on the old firmware is still having issues, so I’m going to update that one today. Hopefully bad firmware was the cause. I’ll report back in a few days.

1 Like

Updating the firmware from to seems to have resolved the problem. It’s been solid for a week after updating. Thanks again for the suggestion @SlabSlayer. I’m surprised this issue was not listed as one of the known issues with

1 Like

Honestly, there are very few users who mount their SD cards in a computer on a regular basis and inspect the file structure, even during Beta testing. You are the tip of the spear on this one. Thanks for reporting it though. I will know where to refer users if it comes up again.