Sensors on sense hub not following rule end time

I have multiple sensors connected to my sense hub. One motion sensor and the rest are door sensors. I have a rule to turn on notifications at 11pm and turn it off at 8am. Every day a different sensor doesn’t turn off notification in the morning, it’s pretty random which one stays on. Here is what I tried

  • initially they were all on the same rule and I thought maybe I have too many on one rule (2 camera, 3 door sensors and 1 motion sensor). I figured maybe that’s too much on one rule so I broke them into 3 rules (1 for the camera, another for two door sensors and last for a door sensor and motion sensor. Still the same issue

  • I figured maybe because they are all triggering at the same time. So I staggered the rules by 2 minutes. First rule starts and ends 2 minutes early, second rule on time and last rule 2 minutes late. Still the same issue.

The rule for the camera always turn on and off but the sensors are the ones with the issue. I believe they all turn on every night (when I check them they are on) but they are just not turning off.

Try two rules: one for start and one for stop. Overnight rules sometimes don’t work correctly.

1 Like

Thanks, I’ll try that

What does your rule history show or indicate? What other rules do you have?

The only other rules I have are for a couple of lights to turn on and off and I have a rule for the cameras to restart every day at noon.

I didn’t know about the rule history. I just checked it and it shows “failed” or “partially succeeded” for the ones that didn’t trigger the end time.

I tried to split the rules. One for on and one for off as you suggested and this morning the Off failed

That is very unusual. Would you please post a screen shot of your rule?

Here are both rules. The “notifications on” at night and the “notifications off” in the morning

Your rules look fine. I’d have to guess something in the rules engine is broken. You might try creating a rule with just one device to see if a new rule works when the old one doesn’t. I’d suggest contacting support, but I know how frustrating that can be. Maybe @WyzeJasonJ or @WyzeMatt may have other suggestion or know of an existing problem.

Thanks for your help and for the suggestions. I’ll keep missing with it and see if someone have more ideas.