Sense hub flaky connection

Sense hub has been flakey the past month. About half the time it’s connected and the other half it’s not. Reset it mulitple times, re-added it to the app, moved it around - still flakey. No other device has any connectivity issues.

Contacted Wyze support today and they concluded that my network is insufficient to support the Sense Hub. Meanwhile, shows 147 MBPS download speed and 99 MBPS upload speed. I can stream 4K video no problem. But… not enough to support the Sense Hub, according to Wyze.

Just be aware that wyze is going to try to blame your network for any connectivity issues. And, it’s ironic that they sell all these connected devices but then if they don’t work, they’re going to tell you you have “too many devices”.

Funny, I have only 14mb down and 4mb up and my hub is working just fine.


1 Like

To help with your connection issue, can you tell how you have the hub connected into your network? Ethernet cable or wifi? If you have it on one, have you tried the other connection type for troubleshooting?

Sometimes “network” problems aren’t just the average bandwidth. Things I’ve noticed that affected my connectivity in the past:

  • ISP
  • DNS
  • Cable Daisy-chaining issues
  • 2.4gHz congestion/interference issues
  • 5GHz SSID and 2.4GHz SSID with Matching vs Diff names
  • Memory Leak issues
  • Router Performance limitations (Ram, speed, total node limits)
  • Router features (QoS, WMM, Auto-blocking)

I went into a little more detail on all of the above variables here:

Once I resolved all of the above, my IoT devices (From Wyze and elsewhere) have all been really reliable, and I have well over 200 Wyze devices alone, including the hub with tons of sensors. Mine hasn’t been flaky at all in the last year since I addressed all of the above.

That’s not to say that there aren’t things Wyze can do to improve the experience people have. The VP of product also acknowledged that they are working this. When asked what plans they have for improving stability and connectivity, he responded:

So they are still working toward improving this. For now, if Support indicated there isn’t much more they can do from their end, consider looking into some of the items in the list I mentioned. It made a huge difference for me back when my Wyze devices were being flaky and driving me crazy.


Wyze uses a Network Diagnostic tool to scan local networks and identify possible issues:


I ran that app for the tech, that’s how she “concluded” that the problem is my network. The tool showed “too many devices” - 30 and “too many other wifi networks”. Both of these are non-issues. See my later reply.

So on my network I have

4 wyze cameras
2 wyze video doorbells
2 wyze locks
wyze thermostat
nest thermostat
wyze vacuum
routinely streaming 4K video for hours at a time
routinely video conferencing for hours at a time shows 147MBPS download speed and 99MBPS upload
several computers and tablets
several smart home speakers and displays

I don’t have any connectivity problems with any of this. Only the sense hub.

I’m supposed to believe this is a network issue?

Is it not possible that the flakiness of the sense hub is due to some kind of failure or defect of the hub? The hub worked fine until about a month ago, then started losing connection periodically, and now it is mostly offline.

It’s the height of irony that Wyze sells probably millions of connected devices. Then when one of them goes bad, they blame the network.

1 Like

Network congestion is one of the main problems with IOT devices. I’m starting to use more things like sensors and light switches that aren’t Wi-Fi and connect via a dedicated hub which is the only true network device. Fewer connections and better, more reliable actions.


Yes, all my devices, IoT and otherwise, are all 100% reliable. EXCEPT FOR THE SENSE HUB. That’s why it sucks that Wyze is trying to blame my network instead of the obvious issue that the hub has failed.

I have the Sense Hub as well. Save for a Firmware issue last year, it has been absolutely rock solid. But I have it connected by Ethernet.

It may be possible to configure your router to give the hub top priority so that you can definitively rule out network congestion.

@bigchipmunk, have you tried Ethernet? Is that an option for you?

Ethernet not an option.

Thanks for the tips, really. But, it is just absurd to me to call this a network issue and I believe that Wyze is shirking responsibility for their product. Hopefully they respond to my support ticket and agree to replace the unit. If not, then I’ll buy another one so I don’t lose my whole investment in sensors, and when that one works fine (the way the current unit did up until a month ago), I’ll be interested to see what Wyze says then.

Have you done a soft reset or a hard reset on the hub?

What is your firmware version?

Multiple, multiple times. Latest app and firmware versions. Went through all that in detail with Support.

Best of luck with the issue. Hoping support can solve the problem for you.

I opened another support ticket and Wyze finally agreed to replace the Sense Hub. I received the unit and - guess what - it has been 100% rock solid since the minute I installed it. So, the problem was NOT my network, the problem was a failed Wyze product, as I tried to tell them over many hours over several days trying to work with them.

My complaint is that the RouteThis app brings up false positives that unfairly blame the customer’s network, even in a very clear cut case of a failed product. Wyze tried to claim that even though my network routinely supports multiple 4K HD streams and video conferencing without blinking an eyelash, it was insufficient to support a Sense Hub, which requires, I’m just guessing, 0.001% as much bandwidth. It just doesn’t make any sense.

RouteThis claimed two “problems” with my network, the first being “too many devices”, 30 to be exact. I will hazard a guess that most networks have at least 30 devices, particularly if they are a Wyze customer. Wyze Plugs and my Wyze Vacuum count against this number, even though the bandwidth requirement of all of these together is basically zero.

The second “problem” claimed was “other wifi networks interfering”. OK, I have a printer and a thermostat that I haven’t bothered to shut off the access point, but the point is, neither of these interfere with anything else on the network. When I checked with the WiFi Analyzer app, the other wifi network signals were 20 decibels below my main wifi, and given that this is a logarithmic scale, these signals are 2 logs (100 times) less than my wifi signal. Since when is 1% of interference an issue?

My belief here is that the RouteThis app is measuring ticky tacky, basically irrelevant factors, and then Wyze is using those to blame the customer’s network, even in the case of a clearly failed product.

My request is either that, the RouteThis app be reworked to measure only relevant metrics, or the Wyze staff be better trained on interpreting the RouteThis output, or that Wyze stops using the RouteThis app.

I think conceptually, RouteThis is a great idea, it allows Wyze to get insight into the customer’s network that they otherwise could not get. But, as it is now implemented and used, it is not fairly representing what might be a product issue vs what might be a network issue.