Sense/Bulb rules not triggering?

Anybody else having trouble with certain rules triggering? Two of my 4 motion sensors in the past few days are no longer triggering rules to turn on bulbs. Though interestingly the rules to turn off the bulbs when motion has been clear for 15 seconds IS still working.

The bulbs are working appropriately when controlled by the app and the motion sensors are both detecting. I’ve tried deleting and re adding both devices and deleting and re adding the rules but it’s still not working. I also tried swapping out the bulb with no improvement. My other sensors and bulbs seem to be working fine with my rules.

When I look in rules history, the rule to turn off the bulbs shows up as successfully run, but the rule to turn on the bulb doesn’t show up in the history.

Submitted log 74356. I haven’t had a chance to contact support due to my work schedule.

I had some stop working yesterday/today, I rebooted the camera & bridge my sensors were on, the lights, and my router just to be sure. They all started working as normal again right after a reboot. It happens sometimes.

1 Like

Yeah I’m used to the sensors temporarily not working. A reboot didn’t work this time because the sensors are working, they just aren’t reliably triggering the rules they used to trigger. I even tried swapping out sensors and bulbs from other areas that were triggering rules just fine and suddenly in their new locations they are not triggering the rules. Signal strength is good. So it seems to be a problem with the rules processing.

But that doesn’t make sense if they work fine in one location, then stop when you move them to another location. The rules shouldn’t have any idea nor care what room they are in. If they’ll work in one room, then suddenly stop when you put them in a different room…how could that be the fault of rules? It doesn’t make any sense…

I had some similar issues a long time ago, and personally had to buy a second bridge. Once I had 2 bridges covering different smaller areas of the house, everything worked a lot better.

I didn’t just move the sensors, I also incorporated them into the rule that wasn’t being triggered. The sensor that had been triggering rules in its old location but once incorporated into the new rule in its new location it stopped triggering.

It’s a head scratcher since they’ve worked without major issue for over a year. It confuses me that the devices all work normally when assessed in the app, the only issue is some (but not all) of the rules aren’t being triggered.

I’m going to try replacing the batteries since the sensors are 9-14 months old, though in the app the battery strengths all read as normal. If that doesn’t work I can consider adding a bridge but honestly if it comes to that I’ll probably just wait for the new Sense devices and upgrade.

Hmm, you could be right about a bug with the rule.

Maybe try creating a new, separate rule? Perhaps it’s something really weird, like one of the data sectors the rule is on in the cloud storage is corrupt or something. So just disable it temporarily, create a new rule, and see if it works now?

1 Like