Sense Bridge Firmware Fail

After a couple of attempts to update a Sense Bridge firmware from 0.30 to 0.33 the unit seems to be bricked. It dropped out of the app and will no longer show up. I’ve tried power cycling the Cam with both the software and pulling the plug; with the bridge both connected and disconnected but the bridge is never seen. The LED lights up on the bridge initially when plugged into the Cam but then goes out and no other status reported.

I made the mistake of trying to upgrade the firmware on a Cam Pan. I don’t know how many people are successfully running the bridge on a Cam Pan but I’ve found it to be unstable and Wyze support said that others had better success using a higher wattage power brick than what shipped with the Cam Pan. I’m guessing this may have played a role in the failed firmware upgrade but I’ve moved it to a Cam and it hasn’t helped recover the device.

I had the same problem with one of my Pan Cams out of four. This Pan Cam and it’s bridge always gave me issues. I pulled the bridge, power cycle it, insert the bridge bridge back in, waited until bridge light went solid blue, and viola, successful update from .30 to .33. Hope this works for you.


Yesterday I tried to upgrade the firmware version of the sensor bridge from 0.30 to 0.33 which failed. My previously working fine sensor bridge now is not recognized by the wyze cam(s) anymore. The Status lights first turns blue and then turns off. I tried power cycling the cam, the bridge and combinations of both. Also tried the reset button on the back of the bridge but no success. The bridge seems to be stuck after the failed upgrade. I filed a request for help to tech support so I have a ticket but no response yet. The cams I tried are all wyze cam v2 with the latest firmware version.

Hi @c.battistella,

Did you get a reaction from the tech support? I have the exact same problem as you.

I just hit the same problem, is there any solution yet?
I upgrade my Pan and Tilt now the Bridge fails to update / upgrade.

I just found the solution, form the support bot.

  • Open the Wyze app, go to the Account tab found on the bottom right.
  • Then tap Firmware Upgrade.
  • You can upgrade the firmware of the specific camera that the Bridge is paired with, or select the Upgrade All button on the bottom.

This got the bridge to update / upgrade.


I have the same issue as the OP. Recent solution does not work for me as the cam is already latest firmware.

If at first you fail, try, try again. I was able to get the bridge to finally upgrade after maybe 4 or so attempts. Be sure to power cycle the camera before each attempt and as mentioned, wait for the bridge solid blue light before starting it’s upgrade. (hosted on V2 cam)

I’ve lost count on the number of times I’ve power cycled and retried.

RE: “wait for the bridge solid blue light before starting it’s upgrade”
Not only does the blue light comes on than turns off immediately after a few seconds.
The option to upgrade it no longer appears in the device info.

I even left it plugged in for over 24 hours thinking maybe it just needs some time to boot back up.
I was wrong. Light was still off the next day.

1 Like

You won’t get an option to upgrade the firmware until the camera decides it likes the bridge. That didn’t happen for me until I manually reflashed the camera from rtsp to stock firmware.

If you are not in that relm of flashing firmware or it won’t present an upgrade prompt in any of your cameras, then I would say the bridge faulty.

After contacting Wyze support about it they agreed the bridge was bricked and sent me a new one. They are inexpensive enough that I bought another to have as a backup and will only upgrade one at a time.

was having problems upgrading bridge firmware to 33.0 for months?? after reading a post on this site about using a 2 amp power source it work!!!Great Thank You----Forum.


Try removing bridge and sd card. Do a factory reset. Then reinstall everything. I think the sensors are already programmed into the bridge so you should have to repeat that process. Once you factory reset all you do is reinstall bridge and it should pick back up. Even the previous songs on cam should remain.

This is how I got it to upgrade on my pan. Now it seems like I’m back to the previous issue where my bridge loses connection.

A couple of general tips on bridges:

  1. Do use a2A minimum power brick for the cam holding the bridge. Pans come with but require that 2 amps so if possible either don’t use a pan or use a larger brick.
  2. by the same token use the original or a known good cord. Some aftermarket cords will cause voltage drop
  3. If you are using a cover for your cam, remove it. Anything that causes signal drop is bad.
  4. try using a USB extension cord to reposition the bridge. Even a short distance can make a difference.
    Any other tips that anyone has found would be very welcome

Confirmed that using a more powerful USB power adapter allows the firmware update to finish. Thanks guys!!


I gotta say I was skeptical but having recently run into this issue I can also confirm that the update completed successfully using a different 2A adapter instead of the one the Wyze cam came with.

Thanks, for your comments, upgrade for bridge was failing .30 to .33 on Cam v2; I checked the bridge and the light was orange; I pulled it out of the Cam v2 for about 10sec, to cut it from power, and then put it back in; once back in the Cam v2, the light turned blue and I tried the firmware upgrade again and it was successful :tada:

I had the same thing happen. My bridge is attached to a cam and everything else updated except for the bridge. I tried multiple times to upgrade it, powered the cam with the bridge on and off but still nothing.

Finally, what worked for me was removing the bridge and plugging it back into the cam.

1 Like

This worked, sir. Thank you!

1 Like

I have the same issue with an RTSP enabled V2 Cam. I"ll attempt to move the bridge to another V2 Cam nearby. Thanks for the options.

I was told today by support that I have a v1 sensor and they will not have a firmware update beyond