SD cards corruption

I’m using the SanDisk 16Gb cards which I bought at Amazon. I use the same type of the card (in larger capacities) with my GoPro, tablets and smartphones without the problem.

For some reason with some recent WyzeCam firmware the micro-SD cards got corrupted, the older files are no longer being deleted, trying to format the card from within the Wyze app doesn’t change anything – the app still shows 0.7Gb of 14.5Gb available after formatting.

I only have macOS computers, which I know are not great for formatting SD cards due to limited filesystem support, so I can try the low-level format in Windows or Linux – can someone from Wyze please advise me what’s the best approach to that is?

Should I use GPT or MBR? What filesystem should I choose? ExFAT?

1 Like

The card must be formatted FAT32. I’d suggest using the long format of this tool which is Mac compatible:

Official SD card formatter from the SD Card Association:

Note: If you are using a card larger than 32GB (not officially supported), you will need to use a different computer-based formatting tool because the official SD Card Association tool will not format a larger card as FAT32 as required by the Wyze Cams.


@Loki – thank you for your prompt reply.

I’ve formatted the card on macOS using the tool you’ve linked, still videos are not being saved on the SD card.

I’ve also tried to format from within the app which didn’t make any difference as per screenshots.

Do I understand it correctly, that before formatting the app showed I have 0.58Gb free, after formatting 0.7Gb free?

Another screenshot.

Last screenshot

do you have a spare card to try to debunk whether its the camera or the card? if a different card works, its the first card, if not its possibly the format of the cards themselves , less likely then that, both are corrupted, or lastly the camera in which case a format of the camera might help.

I agree. If it’s still showing less than a GB right after formatting, I’d suspect a bad card.

1 Like

Had this same issue when adding sense bridge to my system. Pan won’t even see the card installed.

Well today I found ALL of my SD cards were corrupted and would not format, been taking V2’s out of weatherproof cases and repairing cards on PC… 3 V2 cams and the Pan Cam I have all had corrupted files on SD that caused issues and would not format in the Wyze Cam

Once SD is repaired in PC it works fine in Wyze Cams and can even format in the cams.

WYZE needs to address these on-going SD card corruption issues - FIX The Firmware WYZE
By the way I’m using your WYZE SD Cards

1 Like

Had same issue a few days ago. In my case the Wyze Cam v2 kept on clicking and power cycling around every 5 minutes. I rebooted/unplugged and same thing when I plugged it in.

The clicking was not the IR thing since the cam was offline after clicking and after awhile back online so it was power cycling. Then I tried formatting the micro SD card through the Wyze app and it would not format successfully to completion. The 16 GB card would always say .5 GB free.

So I take the micro SD card put it in a SD card adapter and put it in my Windows 10 laptop. Upon recognition, Windows indicated the card may be corrupted and to scan the card. I didn’t scan and I just formatted the card to FAT32 format via Windows.

Once I did this, the Wyze Cam is functioning properly, no intermittent clicking, and saving files to the card properly as I can do playback. The Wyze Cam and SD card combo is a little over 1 year old.


Exactly whats been happening to me too, The SD card get corrupted and the firmware in the camera starts having errors causing all kinds of issues.

And yet the Forum Mavens claim that this isn’t happening to most users,

The code is so bloated now that a write error to the SD causes the code to mess up other functions…

Same issue here, it’s now the 3rd time that my wyze pan has corrupted the memory card.
And besides that, it doesn’t notify you. So while you think you’re recording, you actually have no recording.

One of my cameras has corrupted two cards already, the second one lasted only a couple of days. The worst problem is that the camera goes offline until the card is removed. That is completely unacceptable. Also the cards seem to be unrecoverable now, Windows won’t even detect them.

Is there any way to make the Wyze cam more resilient to a corrupted card so it can at least continue to be online with it?

Hmm? The program at SD Memory Card Formatter | SD Association that I used formatted both my 128GB & 256GB microSD cards to FAT32 last year.

Are you saying they changed that now with this newer version of the program?

For larger card then 32gb for camera. it need to be format exfat

My comment was from a year ago. Things certainly could have changed since then. Also, I have not personally tried to use it to format a >32GB card.

No, you can have up to 2TB for FAT32.

I know Wyze says 32GB is “max”, but they have never told us the real reason why. The stated reasons are a bunch of hooey.

For the camera anything above 32gb sd need to be exfat format. How I know it the only why I can get a 64gb sd working in mine camera.

That is weird then, since I got a 128GB & a 256GB FAT32 microSD card in the V1 & V2, and they work fine.

1 Like

window 10 would not work, I download a sd format and this is the only way I got it to work.