SD Card only recording

Can I use an SD card only w/no internet trnsfering?

@vjurhere52 Welcome! The answer to your question is yes and no. In order for the Wyze cam and the Wyze app to communicate, you have to allow internet connection on the initial startup to contact the Wyze servers. By my experience, using a 10000 mAh power bank, I can keep my cam recording to the SD card even away from my local Wi-Fi.
I actually used my v2 cam in my truck this past weekend as a dash cam for 3 hours and it recorded for the entire 3 hours non-stop. Others have successfully recorded 8 hours and beyond. YMMV for each use case.

However, for the cam to work at home for a monitoring system, it is best to leave it connected to your local Wi-Fi. :slightly_smiling_face:

Yes - the camera will record locally to SD card in one of three modes:

  • continuous
  • ‘motion’ triggered, recording in increments of 1 minute (whenever ‘motion’ is detected)
  • time-lapse.

However, note that the camera must have internet access when it powers up, or it will not function.

1 Like

That is not completely true, I have been running tests and I cant get continuous recording to work until after it sees wifi at power up, but the time lapse will run the whole time.
I set a tine lapse and set to continuous record on a cam then moved it to my car, drove a few blocks away so I had no wifi and powered the cam, it was on for approx 12 hours before it connected to wifi, continuous recording did not work until it connected to wifi but I had a time lapse of the whole day.

1 Like

Curious - my experience has been the opposite. My V2 cam won’t do a time-lapse recording in the field if it powers up without internet connection to Wyze HQ. It used to work OK for off-line recording (early last year), but following a Wyze upgrade sometime last summer, the feature regressed.

I suspect one reason that time-lapse might be problematic for Wyze is that the camera doesn’t know the time when it boots up without internet (since it can’t connect to an NTP server to obtain time and date). A time-lapse recording is configured by specifying start and stop time/date. If the camera’s internal clock has lost sense of time, it won’t know when to start or stop the time-lapse capture.

I have the same results that you report with continuous (and motion-triggered) recording to SDcard: no internet = no recordings.

1 Like

I am actually doing another test today, but I was surprised when my time lapse did work. The one thing that may have made it work is I set up the time lapse while connected to the internet, so it was already started, then I powered off, took to another site and powered up, it just picked up the time lapse when power was restored. I think maybe the time lapse must be already started when there is still wifi.

1 Like

Thank you, I will test that myself w/a 32GB card. The reason I asked is that I have very low internet bandwidth. However at only $10.00 a month I’m not complaining too often.

Down speed is 12M bytes/s (not bits). Up speed, which really matters more is only 0.78 M bytes/s on a good day. So phone, Desktop, etc. and it gets sketchy and slow/not worth it.

Oh, by the way, what frequency of frames on the “time laps” mode/ver2 latest firmware?

Thankx for the info.:crystal_ball:

I believe your analysis is correct. You were able to program the time-lapse recording since the cam was connected to internet. Then the specified recording started while it was still on-line. The camera powered down. Sometime later when it powered back up, the existing (in-process) time lapse recording resumed.

Here’s a little experiment you could try. While the camera is on-line, program a time-lapse recording, but for a future date/time. Set it for the following day, perhaps. Power down the camera, and leave it off-line until the next day. Then move it to your car, drive out of range, and power it up, as per your previous test scenario. I’m pretty sure that the TL recording will not trigger (since the camera will not have any idea what the time is).

Not because there was “still wifi”, but because there was still internet connectivity. It’s quite possible for a camera to be connected to a WiFi base station, but not have any connection to the internet. For example, one might be in the field (or in a cabin in the woods with a travel AP/router. Cam connects to the router. Smart phone connects to the router. iPad connects to the router. But there’s no internet connectivity. In my experiments, I’ve found that my V2 behaves differently in the two environments.

You can specify the desired interval between time-lapse frames. The shortest is every 3 seconds.

So I did my test, programmed a time lapse in the future, (12 hour time lapse 3 second interval). Removed cam from power and obviously internet and took to another location. Hooked to power, had no wifi, let run the entire time (also had continuous recording set on SD card). Powered off and took back to home location. Powered up and let it grab the internet. Continuous recording to card did not work. Time lapse worked completely had time lapse of the entire 12 hours.


Thanks for the report on your experiment. I will redo my TL use case. I have a theory about what’s going on, and will see if I can validate it. (it has to do with the way in which the camera deals with clock time).

Our results agree on continuous recording mode: if there’s no internet access when camera powers up, that mode doesn’t work. (nor, in my experience, does event-triggered recording to SDcard).

Yes we agree on that, of the 3 recordings that use the SD card this is the current scenario.

  1. Time Lapse - will work as scheduled
  2. Continuous Mode - Needs to see internet connection after power up, but after connection will record even if internet is lost as long as power is maintained
  3. Events Only - Needs to see internet connection after power up, but after connection will record even if internet is lost as long as power is maintained

“Events Only - Needs to see internet connection after power up, but after connection will record even if internet is lost as long as power is maintained”

Can I assume “Events Only” is motion detection mode, sound, smoke detector etc.? In other words will it triger and record motion detected if powered up w/internet and keeping power on it but disconnecting / out of range of internet it will still record on detection of movement? Thank you for your diligence and sharing your findings.


For the testing I did it was only SD card testing, so events only means the recording option to SD card being set to events only.

I’ve run some further TL tests using my V2 camera in an off-line setting. Based on my results, I have to disagree with your bullet point 1 above: “Time Lapse will work as scheduled”. My tests indicate that time lapse recordings do not trigger as scheduled when the camera is powered-up with no internet connection.

I don’t find this surprising. When a camera powers up with no connection to the internet, it’s not able to obtain clock time (date & time) from an NTP server. If it doesn’t know the current time, it won’t be able to correctly activate a new TL recording at its scheduled time.

Here are the details of one of my tests.
Yesterday (Oct 31), my cam with current firmware was on-line, connected to WiFi and thence to the internet.
Around 3:25pm, I scheduled a TL for later that afternoon: start at 5:00 pm, end at 6:00pm, 30 second interval.
At 3:30pm, I unplugged the camera, and relocated it to an off-line location.
At 4:30pm, I connected power from a USB power pack. There was no WiFi.

I left it powered overnight. The battery probably ran out in the wee hours of the morning.
At 12noon, I returned the camera back to home base, and connected it to power. It found my WiFi network and went back on-line.
Using the Wyze app on my iPhone, I looked in the cam’s Album for any TL recording that might have been captured while it was battery-powered. Nothing.

I then pulled the SDcard and mounted it on my MacBook to see if there were any new TL recordings. In the time_lapse folder, I found a new time_Task folder that had been created yesterday afternoon at 3:25pm. That folder contained a log.txt file with the schedule details for the TL recording that I had specified. Such files contain 3 parameters: BEGINTIME, ENDTIME, and TIMEGAP. The time_Task folder did not contain a record.h264 video file. That’s the filename that Wyze uses for TL recordings. Conclusion - the TL recording I had programmed never happened.

In the test that you described above in post #10, you indicated that you programmed a time lapse in the future (12 hour time lapse, 3 second interval), then moved the camera to an off-line location. Is it possible that the TL had started before you pulled the power? If it had, that might explain why your result was different than mine. But if your 12-hour TL was to start some time after you applied power, it’s a mystery why your TL triggered and mine did not.

I am pretty confident it did not start before I pulled power because I pulled power within 5 minutes of setting time lapse, but I am not against the possibility that something went wrong on my end. I will redo my test this weekend and be sure to take care that the specifics match the scenario we are looking at.
Just to be positive here is the scenario I will do unless you see a flaw in it.

  1. Set time lapse to start at a time I know I will be without internet say 3 pm to 4 pm 3 second interval.
  2. Remove power from cam
  3. Go to off-site location prior to 3 pm
  4. Power cam up at least 15 minutes prior to set time lapse time so I know it fully boots
  5. Run time lapse for the hour
  6. Disconnect power after end time
  7. Take back to residence and power up with internet to see if there is a recording

See if there are any changes I should make and I will test git out again.

Just for kicks what app version and firmware were you running?

I ran another test last night. Similar recipe to what you detailed above.
This time, the camera did trigger the TL recording, even though it had no WiFi and no internet when it powered up (nor any time during the test).

However, I’m not sure that the TL ran at the programmed time. Turns out last night was not a good night to do a test due to the end of DST. That messes up the timeline. I might try again tonight.

I have a suspicion that when the camera powers up in the off-site location, its internal RTC (real time clock) gets loaded with the time it had when the camera powered down. Since there’s no internet, it can’t obtain accurate time from an NTP server, so it just picks up where it left off. In other words, if the camera had been without power for two hours, when it powers up off-line, the clock will be behind by two hours. If that’s the case, the programmed TL recording will start two hours later than expected.

This doesn’t explain why some of my recent tests have resulted in no TL recordings, but last night’s test did. The Wyze firmware is a mystery wrapped in an enigma.