SD card not available After Viewing Event List (V2 and Pan)

I killed a V2 and now my Pan by doing what should be a normal set of steps:

  1. Check even list
  2. View a recent event
  3. Return to list of cameras
  4. Select camera that event occurred on
  5. Click View Playback
  6. Receive “SD card is not available” message

Pan Firmware:
V2 Firmware:
Android app version: 2.16.55

I’ve tried different version of firmware on the V2 (even the latest) but frankly ran out of time. And patience. Thought it was the SD card until I got the identical issue on the Pan which is far newer in my home. The SD card from the V2 connected to my PC via adapter works just fine.

Didn’t see this exact topic in the forums, so please excuse if this has already been solved and I didn’t see it!

I just tried your exact steps on both of my Pan cameras and two of my V2 cameras.
No problem at all. The only difference is a different firmware versions. The Pans are the current Beta -; and my V2 cameras have the RTSP firmware.

Between these steps, do you wait for the live view to start before clicking on playback? Let the app connect to the camera, then click playback?

what SD cards are you using?

your sd card may be dying.
Wyze v2 killed my sd card in 8 months.

1 Like

What size, vendor and brand SD cards failed?
I’ve several Samsung 32 Gb EVO from the Samsung store @ Amazon that have been running for over two years and at least one that’s been outside for that time, all in V2’s, no problems.
Mostly used for continuous recording and some for time lapse.
I bought the cards because they were inexpensive (~$6@) and I needed a lot of cards.

Yes. In fact, I don’t think I can get to the live view without waiting. :slightly_smiling_face:

Ok. Looks like the consensus is both SD cards are dying. Seems odd that I can see all of their content my my pc, but need to try replacing them as an option. These are all Wyze-branded SD cards.

Last I checked the Wyze cards are not high Endurance type.

  • Check the disk with the command line C:\Windows\system32>ChkDsk X: /r Where X is the uSD card
  • Format the uSD card FAT32 and un-check the default “Quick” option so it can mask out bad cells.
    Note: The Format from the Wyze App is a Quick Format

While this may get your card to work, it will probably fail more frequently as it ages.

You are correct in that estimate. I have talked to a couple of developers and the wise brand SD cards are not high endurance.

It’s something I haven’t pushed for very hard yet, but I think it would be a good move for them to go high endurance


I’ve had two Wyze cards die but no issues with my Samsung Pro High Endurance. They work super dependable.


I wished for it but not getting any traction. Not a very persuasive argument.
Wishlist (Wyze 32GB uSD High Endurance)

1 Like

Will do. Thanks for the tip!

Will also look for Samsung high endurance cards. Was using Wyze-branded 32GB cards. Pretty standard.

1 Like

Am looking at these. Correct? Is their pro endurance the same as high endurance? Thanks!|SAMSUNG|SanDisk&rnid=2528832011&s=electronics&sr=1-2&th=1

Yes, that is one of several have purchased. Received with an exFAT Format and using as-is.
Today started testing this 64Gb ver. in a V3 outside. So far, so good. . . :slightly_smiling_face:


Good luck with the 64GB. I know they are not “supported” but know they work. Nice!

Bummed to learn the wyze cards aren’t high endurance, I they were. Guess I won’t be buying any more of those. For the record, I think I’ve only had one card fail in 2 years on about 8 cams. I have a variety of brands and sizes (most over 32), but always look for the high endurance when purchasing brands ther than wyze. (Just hope I haven’t jinxed myself. ;-))


As a follow-up, the new cards work fine, problem solved. We’ll see how long the endurance cards work!

Thanks everyone for your help. Much appreciated!