Schedules broken again?

I thought this was fixed, but trying to schedule from 9pm to 4am the next day isn’t working again? Wyze Android Beta 2.5.32.


That doesn’t sound good…aargh! :worried: Thanks for the feedback. I hope they fix it before it is officially released then. @Newshound @Loki @WyzeGwendolyn

Interesting. They say they released a bug fix for that on Android at the end of last month. Thing is, it wasn’t limited to Android, so why did they release a fix there and not on iOS too?

I’m not using the iOS Beta, but the current release version is broke (2.5.45), so I can only assume nothing has changed in the Beta. Anyone got the iOS Beta to test this theory?

So looks like they both still need fixing. Good heads-up!

1 Like

Works here. Note the difference is mine is 12 hr clock and yours is 24 hr.

1 Like

I’m using a 12 hour clock. I see you are in ‘edit rule’ – try ‘create rule’.

I did - I created that rule as a test and went back to edit just to get the screenshot.

So are you on the new iOS Beta?

I just tried it on the latest iOS 13 beta, and the latest Wyze Testflight beta. It works fine. I’m also not using 24hr time. I set up the rule exactly as OP did.

Well, so far we haven’t traced it to 24 hour time. The OP is on Android Beta, and everyone that says it is working since is on iOS Beta. So if we could get an Android Beta person to try it in 12-hour time, we might make a connection there.

In the meantime, it just isn’t working on the Android Beta. Might be 24-hour time.

I have an android phone. Will test and report back


Okay, so I tried it on my partners phone. Their phone is typically on 24hr time, so I tested that first. That didn’t work, so I swapped it to 12hr, and that still didn’t work.

To clarify this is also on the android Wyze beta.


Okay, so the current Android Beta either isn’t fixed yet, or they reintroduced the bad code. Thanks for the test! :+1:


Yup! Let me know if anything else is needed. At least when it comes to betas, because I’m pretty much always on betas :stuck_out_tongue_winking_eye:


Ill be checking mine when I get off duty as well just to see.


I am on the newest beta on Ipad but still on 12 IOS since the new Ipad OS hadn’t been released yet.

I’m on the android Beta version and had this exact thing happen last night. My current rule is set for the lights to come on from 8 pm - 5 am (shuts off at end of rule) but since it’s getting darker way earlier I went to adjust it and got greeted with the message that it couldn’t be done. I almost erased the rule (which I would have been so mad about) but decided to test out adding a similar rule. NOPE currently android Beta version will not allow you to make rules that go from any PM hr thru After midnight. This needs to be fixed again.

1 Like

Hey, folks!

Looks like I need to clarify something here. Right now, schedules that start on one day and end on the next can’t be created. There was a second problem when we made the original Rules change where schedules started and ended late on the same day couldn’t be created and that part was fixed. We have adding overnight schedules on the list of things to address and we apologize for the inconvenience in the meantime. For now, setting two schedules should function as a workaround.


My work around set up shortcuts for AM PM on another device with app 2.4.82

My Group (3 bulbs) was working 8pm-1am, then I changed to 7:30pm-1am and they don’t work. Finally got them to turn on 7pm, but manually turn off. I’ve edited rule. I’ve created a new rule after deleting rule.
These bulbs are outside, but protected and do not seem to be affected.
Also tried 7:30pm-12:59pm… no luck.
Original 8pm-1am did work until I changed the on time to 7:30pm.
Am updating to iOS 13.1 now.

If you set up 2 separate rules for this it should work.
One for on at 7:30pm and a separate one for off at 1am