Rules updated

So I got the updated Android beta app, and it appears that, after many requests, you can now “schedule” rules. That’s great.

Unfortunately, it doesn’t work. I schedule a time, from 6pm to 6am. When I go back into the updated rule, and it defaults to 6pm to 6pm. If I try 6pm to 7pm, it defaults back to 6pm to 6pm.

I can only set a time up to 59 minutes. For example 6pm to 6:59pm.

Someone please verify my findings…

I am on iOS so not a true comparison but it is working correctly on iOS.

This is what I see. One example… won’t schedule mote than 59 minutes.

That is not desired behavior. I am going to let @WyzeGwendolyn know to look here. It will be awhile as they are on West Coast time. Thank you for the heads up.


Thanks for letting me know! I’ll tag @NumberOne here. :slight_smile:

1 Like


While were at it, the other Android app issue I pointed out still hasn’t been corrected. The one where changing the resolution of the phone causes the event videos to either be zoomed, or shrunk.

1 Like

I just set a time for a plug to turn on for 2 hours, Seemed to work, will know in 1 hour 55 minutes.
Turned off after 2 hours.

1 Like

This has nothing to do with scheduling a device turning on for period of time. That’s been available for a very long time.

It’s about setting a trigger - like a contact or motion sensor - to turn a bulb on, but only during specific hours (ex. 6pm to 6am), which was recently added to the beta app. The app will not allow setting a time greater than 59 minutes. IOW 0600 to 0700 resets to 0600 to 0600, but 0600 to 0659 works fine.


I have been runnning this type of setup that has a time greater that 59 minutes and haven’t run into any issues yet.

1 Like

That’s really great. I’m happy for you.

But on my Samsung Note 9 it does exactly as I’ve shown, even after fully uninstalling, clearing cache, and clearing data, so I’m not sure how your comment is meant to help me.


Hi Rick, I tried on my Galaxy Note 9 which worked just fine with your scenario. I can set my trigger time for over 59 minutes. Actually it is great that you have a consistent repro. Can you please upload an app log through Account → Help & Feedback → Report an Issue right after you fail it? Adding an video recording in your issue report will be even better. Please reply here when you are done. We will take a look early next week. Thanks!

Thank you for reporting the issue. We really hope to catch the issue with your help!

1 Like

@WyzeTao - Thanks. Ticket number is 363501 or 363507 or 363513. For some reason, after I reply to the support email (first with a video, then with my comment below about 24 hour time), it sent me a second and third support email with those ticket numbers.

In the meantime, I’m going to see if it’s related to my 24-hour setting of the phone.

EDIT: So that’s the issue. When I switch off 24-hour display, and set a start time to 6pm and an end time to 6am, it works fine. If this can be fixed, that would be perfect since I am in the Army and use 24hr time exclusively.


@None - You figured out the puzzle. :smiley: It was 24-hour format setting. I changed my phone to 24-hour format and got a repro as well. I will pass it to our devs. Thank you!