Scheduled Watering Skipped after Quick Run (Skips turned off)

I have automatic skips turned off, but if I use quick run, my next scheduled watering does not run, even if it is 4 days later. So now I can only use quick run because my scheduled watering always skips. The schedule always shows it’s scheduled to water the next scheduled day, but then it doesn’t.

Resetting and completely re-setting up the controller and schedule is not an acceptable fix to this. This could be fixed with just a few lines of code.

Please add an option to turn off skipping after running quick run earlier in the week.