RTSP regenerate URL

My first post so go easy.
I have successfully been able to use RTSP with my qnap nas. However, I have to regenerate the URL quite often or it won’t record on my nas drive. Is there a way to fix this issue? I should not have to regenerate the RTSP URL everyday.

Have you assigned the Wyze Cam a static IP from the settings in your router?

Yes I have.

I have a similar issue with RTSP on ~10 cams and iSPY on a Windows PC. It improved when I switched from TCP mode to UDP mode in the iSPY app, but still happens. (Improves = went from multiple times a day to ‘only’ a multiple times a week.)

I’ll make the change and see if that works.