RTSP in iSpy

So in another thread I mentioned an observation that the RTSP feed seemed to stall significantly in iSpyConnect. This scenario seems to be alleviated by setting a “Reconnect” timing under the advanced properties of the Source. I am guessing this is equivalent to a RTSP Keep-Alive setting in other applications. I set it to 30 secs. Not sure why this is necessary since it is not necessary with other RTSP supported cameras such as my TP-Link NC230s.

A further observation is a random momentary graying out of the entire screen, especially whenever movement is detected. This graying out issue is not great. << Anyone else testing with iSpy?

Experienced my first disconnect for unknown reasons in iSpy. Important to note that while the RTSP feed was offline, the normal feed through the WyzeApp was fine, indicating that the camera was up and running (V2).

Further verified the RTSP feed was not available and it was not an issue with iSpy by trying to connect directly with VLC.

The connection was re-established by simply regenerating the RTSP URL under Adv settings in the WyzeApp. (Note here that RTSP was not switched off and back on as I believe others have reported. The only action was to choose to regenerate the URL)

1 Like

I believe this has also been reported but I’ll report it here too. The audio does not sync with the video. Interestingly in the WyzeApp, the roles seem reversed.

1 Like

I used iSpy, so I noticed if I put the camera into inactive mode, it will not turn back on when you simply click the “Active” icon. A quick fix is to click the “gear” icon, then click the source […] without changing anything (the previous generated URL is still there) and click “Finish” at the bottom. The camera will be back on. Why so I have no idea, but it is the current situation for my iSpy.

I don’t see that issue although I am using iSpy 6.3.3.
When I choose the activate icon, it can take up to a minute or so to come back online… not different than the other RTSP camera brands I have connected.

I use iSpy v7.180 and this keeps happening - if I turned it off and try to turn on, it will not back on unless I go to the source to “re-activate” it. Yes all the URLs remains the same, just “re-apply” the source then it come back in seconds. Does not make any sense to me.

Also like other mentioned sometimes the screen went grey, or go offline itself.

We hope for some improvements with the next release of the firmware. The grey screen thing is annoying since it will trigger motion recording. Worse, if the grey screen appears at a critical moment in the recording. I have 2 V2s and one of them does the grey screen thing a lot more than the other… weird.

I had a similar problem with I spy
Dropping Ip cameras that had worked fine before adding the wyze and dropping from the Wyze app Group view
I had RTSP on a V2 . After taking the RTSP V2 offline all other cameras are now working
Installed the the .37 firmware with No RTSP and no cameras are dropping
Will wait til bugs are gone.
I really liked the ability to record video directly to my hard drive

Still seeing the intermittent gray screen with firmware .40.

Anybody having any better luck with RTSP in iSpy?
Added a couple more V2s to my iSpy for a total of 5 and the performance is pretty bad. Everything from the grey screen popping up, to loss of connectivity.

One really concerning observation is that the image in any of the of the feeds can freeze while the framerate counter keeps going, as if the feed is still good. Makes me think of the movies where the high tech robber spoofs the image of the CCTV while doing the dirty.

Yeah, I’m experiencing the same thing except I’m recording with MotionEye on an RPi. After about 10 seconds the lag starts and pretty soon it’s is almost a minute behind. Then it goes to grey screen. This happens every time I reset the camera. Think I’m going back to stock firmware till this can be sorted out.

I’ve recently figured out if I go above 4 wyze cameras in iSpy, the amount of disconnections goes up significantly. (It still isn’t great mind you… with 4 or under I can go a few days, 5 or more I can make it a few hours if lucky.)

Interestingly, I installed iSpy on a 2nd PC and can run 2-3 wyze cameras there (at the same time as running 3-4 on the first PC) and both PCs seem to hit the ‘ok for a few days’ state.

Per perf monitor, neither PC seems to be hitting resource issues (CPU 10-20%, Memory ~50%, disk ~nil (as I am not recording video), ethernet less than 8Mbps, GPU less than 10%)

A couple of other notes
I am NOT recording, only using them to show up on monitors
I use RTSP Mode = UDP (rather than the default of TCP)
No audio

Has anyone here tried using the Dafang hack? It is much better for RTSP use than the Wyze RTSP firmware. Works very well in Blue Iris, and I bet iSpy too…

Dumb question - do you lose wyze app connectivity with Dafang?

Absolutely, that is one of the big benefits. :slight_smile: