RTSP Download issues

Hello Wyze Family,
Question on what is most likely something that is a user error. For some reason when I go to download the RTSP link and unzip the folder it is being unzipped as a Windows Media Player file instead of a BIN file… No idea why, but have tried 100 times and still unzipping as a WMP file and when I try to copy over to the SD card and input it takes me through the normal cycle of setting up the camera.

I installed the RTSP BIN file on one SD card successfully a few nights ago and when tried to do the others I ran into this issue, which further leads to my confusion. ANY help is greatly appreciated as I troubleshoot this likely user error issue.

Many thanks, and appreciate any guidance.


First step, do you have Windows set to hide filename extensions? If so, turn that stupid feature off. My guess is that somewhere along the line, something assigned .bin files as a Windows Media Player file, and because you are not seeing the extension, you can’t tell that it really is a .bin file because the extension is hidden.

1 Like

My guess (and I’m a Mac user, so take it for what it’s worth) is “.bin” is associated with Windows Media Player on your computer (can’t imagine why, tho). When you transfer that to the SD card’s root directory, it may still say that, but the camera will never make the same association to what your computer thinks a “.bin” file is. It will simply look for a file name that starts with what it expects, and ends in “.bin” (note “demo.bin” only works on original devices, and not newer models like the V3).

So I guess don’t worry about it unless it appears to be interfering with your efforts.

1 Like

I’m also seeing this issue. I’m using a SanDisk Ultra 32GB Class 10 card and formatted it using the camera (Wyze V2). I then downloaded the Wyze V2 RTSP firmware, copied it to the root of the microSD using the command line on a Linux computer (no hidden file extensions) as demo.bin, inserted it into the camera with the power off and turned it on with the setup button held down. I get the orange light and then “ready to connect.”

From the digging I’ve done it sounds like a number of folks have run into this. Some have seen it with some of their cameras and not others. This page theorizes a correlation with the second part of the string contained in the QR code:

My camera doesn’t have either of the codes listed there, it has Y00A0030. I just updated it to firmware

Did you copy the downloaded file, or did you extract the downloaded file then rename the now downloaded file? I know you posted the exact same step you took on a different thread, just making sure a step wasn’t passed over.

Sorry I left that out of the steps I did, yep I unzipped the downloaded file before renaming it to demo.bin.

Okey dokey. What about formatting the card in the computer as fat32 then copy the demo.bin over and trying that in the camera? Different card on hand to try? 32 gig or smaller.