Room Sensors keep getting removed from Comfort Control

What is the temp threshold on the remote sensors?

Mine is set to.7 degrees.

My experience is exactly the same. When I first got the thermostat, I kept having to re-add the room sensors to Comfort Control every few days. Some of the things I read indicated that it might be due to the Motion-sensing Comfort options auto-removing them, or the threshold temperature causing it to be excluded, so I turned off Motion-sensing Comfort and at some point things were stable, so I assumed that was the cause of the problem and it had been resolved.

However, now I want to remove one of the room sensors from Comfort Control and it keeps being added back automatically after a day or so. I’m fairly certain that this is the same problem that was happening at the start, and that there is some bug that causes Comfort Control to revert to a previous state.

It is frustrating that this issue has been ongoing for so many people for so long and Wyze chooses to ignore it. Clearly this is a bug in their system. My sensor gets excluded at random intervals for no apparent reason. I do not have motion sensing comfort enabled (though it should not make a difference.

1 Like

14 months later and this still hasn’t been addressed. I have 10 Wyze thermostats, having previously been a huge fan of Wyze products, although it’s hard to justify that these days, all 10 of them have room sensors. all 10 have the latest firmware on Thermostats, and all 10 of them drop room sensors sporadically. I’ve seen within 24 hours to weekly from my notice over the past 2 months. it’s constant.

We have one building that shares a common hallway and utilizes 4 thermostats, and has suffered errors from over cooling, and under cooling the 10 offices as a result of hallway-based temp readings. I decided to heavily invest in Wyze thermostats for all offices having loved my house thermostat, and decided to try the room sensor in my house, as well as in all offices.

It is such a falsely advertised scam. Has anyone got these to ever work right? Literally 10 out of 10 are failing… I’ve tried switching phones(apple to Android), updating apps, and leaving the Beta app program, and nothing has worked. Tried calling in for support that was beyond underwhelming and inefficient as they could barely read the screen prompts… And even then they sent me an account credit for the black Friday deal price($18)… which wasn’t even enough to buy one in the Wyze store($25).

Customer service has fallen immensely. I miss the days of the Facebook group getting all the attention us loyal followers deserved. Now it’s just cheap disposable crap.

Same thing for me as what ChartreuseBison said above: any time the thermostat restarts, the room sensors are excluded from comfort control and you have to add them back. You can easily reproduce this problem by going into the thermostat settings in the Wyze app, scrolling down, and tapping the Restart button.

Having the same problem where the sensors get removed from comfort control every couple days. Very frustrating since I paid a lot of money to switch out my old smart thermostat to a Wyze one due to the sensors feature. Only thing I can think of is that when I first set them up I turned on motion sensing control. Didn’t like it and it has been disabled since but maybe there is some flaw in the code that makes the motion sensors continue to remove the sensors from comfort control even though motion sensing is now off.
I have three sensors and all three get removed without me doing anything. Thermostat firmware is 1.2.7.

Does anyone have this same problem that is sure they have never enabled motion sensing (even by accident for a second)? Has anyone tried removing all Wyze devices from their account, deleting the app, then reinstalling and making a brand new Wyze account (along with manually adding all devices)? Would be a drastic fix but would be worth the effort if it solved the problem.

I think you are right I am betting it is the coding getting confused when you have motion control AND it in the comfort group, it has to be one or the other, I just turned off my motion control and am crossing my fingers! TY!

This has been going on since I added the room sensors,

I did not start with the sensors, they were ADDED LATER. I do things in stages… ie: Get thermostat, install, run, its working? Yes. Move to next stage, add the sensors…

For about a week or so things were fine… see other post in re “sensor math” in trying to reverse engineer what math the sensors and thermostat firmware is using,

Motion Sensing is OFF, and its NEVER BEEN ON.

NO “modes” ie: home/away/sleep. Never setup, or used ever.

Thermo Firmware: (Current) - 1.2.7
Sensor Firmware: Current - 1.1.0
Sensor Plugin

Wyze App - V2.4.8.1 (381) Android - Various devices Samsung and onn Tablets

Balanced Mode / 5 Degree

NOT in the Beta Program - EVER. I have NO INTENTION OF IT either.

MY GOAL is simple: Sensor 1 + Sensor n + Thermo Temp / 6 (5 sensors + Therm) = y Home Temp = What the therm should determine the HVAC should be on be it heat or or cool. NOTE: This is NOT the math the firmware uses!! Not even close… and nope I have no idea what it is, but it is NOT THIS.

The MAIN Room Sensor I want used, is in the same room WITHIN 12 FEET of the thermostat. Another is about 15 feet away, another is 20feet tops. I’ve got two more that are about 30 feet or so away in other rooms… I’ve NEVER NOTICED missing readings on the sensors One of these sensors will be relocated as I have Climate Sensor there to now determine the temp and operate a plug… although I might leave it since as I can just look the Room Sensor LCD which is nice… (NOT glued to a phone/tablet here!)

I recently ADDED the Alarm/Sense Hub along with “Climate” sensors… I have one outside ( I have it in my own DIY Waterproof box/Stevenson Cage type setup) … I have a rule(s)

If Outside Temp < x then HEAT ON!
If Outside Temp > y then COOL ON!

Thats been working well, with one glitch. has NOTHING to do with the Room Sensors.

I’ve quit wasting my time checking to determine if the sensor I want used is still part of the setup… It lasts a day, a week, or maybe less… I quit…


I am not here to babysit this setup, be it these things, or cameras or any of this stuff.

So I am not sure what the issue here to cause this to drop out… but … .

THERE IS AN ISSUE which needs addressed.

Thanks for your detailed post. I am now inclined to agree with what some other posters surmised—that the problem is as simple as the thermostat removing the sensors from comfort control whenever it restarts (and it apparently restarts itself regularly for some reason). Lately, I have had to re-add my sensors nearly every day!
Not sure the best way to get Wyze’s attention to this issue. Judging by the fact that a simple feature like displaying the temperature in Celsius on the sensors has still not been added, I can’t help but feel that nothing will be done regardless of what users do to complain and that we’ve all wasted a lot of money.
Hopefully one day either Wyze gets their act together in the software department or some third party figures out a way to use their hardware with custom software that actually works!

I’ve been dealing with this exact issue for months. Almost daily, one of my sensors will be removed from comfort control, and I have to re-add it. I’ve contacted customer support, and after following all of their troubleshooting steps with no luck, this was the response:

I appreciate you for taking the time to try resolving the issue by performing the troubleshooting steps we recommended. I understand it can be frustrating when problems persist, and I apologize for any inconvenience this may have caused. Please be assured that we’re here to assist you further.

In this situation, we must escalate the matter to our system engineers for further investigation. They will thoroughly examine the issue to identify the root cause.

Please note that app logs are sent directly to our engineering team to use towards improving future app and firmware releases. These logs cannot be accessed or followed by our support team. We’re working on developing a process so that we can track these logs but it’s still very much in progress.

You can rest assured that our system engineers will thoroughly investigate the root cause and work on integrating the missing components into our system. As for the estimated time frame for the resolution, we are unable to provide one at the moment as the resolution is currently undergoing testing to ensure there are no additional issues before its release. We truly appreciate your understanding and patience throughout this process.

Does anyone know of any updates, if a fix will ever be coming? It’s very frustrating to feel forgotten by a company that is too busy releasing camera after camera while forgetting about existing customers.

The only reason why I haven’t switched to a different thermostat yet is because I need the room sensors, and other room sensing thermostats are quite expensive.

But on that note, at this point I’m done with this thermostat. Boiling hot rooms are the norm at this point, and I don’t think this will ever get fixed.

What other thermostats do you guys recommend, that have room sensors? Ecobee? I heard Sensi just came out with sensors?
I also have a Home Assistant system, so something that will work with that would be nice.