Room Sensors keep getting removed from Comfort Control

I have multiple thermostats. Most with room sensors attached. I have each one set to “Motion Sensing Comfort” “off” Various reason why, but our system is hydronic doers not heat fast enough for motion sensing to be efficient when we need it. Also we have some very poorly positioned thermostats so we rely on the room sensors to give an accurate read of the zone.

That said, we are constantly having to re-add the room sensors back into Comfort Control when the system removes them. How do we prevent this from happening?


Have you tried clearing your app cache in account > app settings, then force closing the app. Also, about how often do they get removed? Are you sharing your account with anyone, or sharing the device?

Seems random. Some days everything is fine, some days I find 4-5 room sensors that have been removed.

I have been having the same problem. I have two thermostats with 3 sensors tied to each thermostat with motion turned off on both. I randomly have to re-add them to included in comfort control too.

1 Like

I have experienced that as well. Although, now I find the sensors added back to the comfort list after I remove them. This happens every few days, and I know when it does since our home gets too hot due to a sensor being included in the temp calculation that I explicitly remove over and over.

Does anybody know if there is a permanent fix for this? This is quite frustrating to constantly add the same sensor back to comfort control after it drops out. (No motion selected)

I have the same problem. The dining room remote thermometer removes itself from the “included in comfort control” group randomly. Just one remote sensor included in the group and occupancy sensing is off. I tried a factory reset, it didn’t help. I’ll try clearing the cache.

Can you all provide the FW version of your T-Stat?

Also, I experienced this issue in the past and moved it a little closer to the T-Stat and it remained connected. Something to try to see if this corrects your issues.

Version 1.2.1

Yea, that is the latest Prod FW.

Can you try moving it closer to the T-Stat?

Same problem here and my devices are about 5 feet away from t stat. Through either a door or a wall. They remove themselves around 3 days. I only noticed bc my bedroom gets hot or cold at night and I am like why am I sweating. Ohhhh it switched again. Latest firmware and cleared cache. Even uninstalled app. Also tried removing device and re-adding them. Starting to get frustrated bc the only reason I got them was for this reason. Their main function.

Thermostat FW is 1.2.5

All Sensor FW is 1.1.0

That is the same as I have. I am not experiencing the issue anymore.

Curious what happens if you move it closer.

Are you on Android or iOS?

I am Android 13

I really don’t have an option to move it closer. Then it wouldn’t be in the room. Actually one of them is less than 2 feet away. They are back to back with only a wall between them.

I can’t move it much closer or it will be in the same room. I relocated the remote sensor so that it is in direct line if site to the thermostat. (Through an open doorway). Waiting to see if this helps.

1 Like

Ok. More of a question.

I had mine in one spot which kept doing the same as you. I then moved it to another location to eliminate walls and kitchen appliances and it worked better.

Recently, I moved it back and have not experienced any issues yet.

I have 2 sensors in close proximity to the thermostat and they both drop out after a few days. Latest firmware and I have deleted and restored. I think this is a bug. My thermostat is first gen - got it when they first came out. Wonder if that makes a difference. Those that have a similar problem, is your thermostat first gen, too?

I don’t know what generation, I bought it in December from wyze com.

@spamoni4 So, after about 5 days the remote sensor dropped from the group again.

I would call Wyze by going to and using an option there or calling:

Make sure you get a Ticket Number and also submit a log of the issue, then post here.


I am running a different version than you, so it may be fixed in a more recent version. Unfortunately, it has been held back. To test, I put mine back where it was dropping, like you, and it has remained connected.