Robovac factory reset?

Is there a way to reset this damn thing? I came home to find the vac stuck up against a table leg, smelling like burning wires. Its unresponsive to the app and home/power buttons. It’s currently sitting upside down on the counter with the wheels turning until the battery runs out… :roll_eyes: Tried to connect to the charging station thinking that would do something but it’s stuck in reverse. LOL

You should be able to reset the vacuum by following the setup process. Wyze Robot Vacuum Setup And Reset Guide
If that doesn’t work, you may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

1 Like

@cyclone87 Sorry to hear about your vacuum.

How to factory reset Wyze Vacuum:

Press the Home button for 5 seconds and release it when you hear “Factory settings will be restored. Then press the Home button again for 5 seconds until you hear the voice prompt “Restoring factory settings / Factory settings restored successfully.


Thank you. I tried holding the buttons but the machine was unresponsive to anything I tried. I stuck it on the charger the next day once it was completely dead. Aside from running dead a few times without returning to home to keeping cleaning logs, it’s working again. This thing is great when it works but when it doesn’t…

1 Like