Robotic vacuum firmware update - when will it ever finish?

Around 1pm today, I was about to send the robot on it’s rounds to clean the house. Got notice that I had new firmware, so why not? Kicked it off, but it is still going 3 hours later! Is that to be expected, or should I just kill it and try again later?

Update: I decided immediately to kill it, but I can’t. When I try to send the robot on it’s way, it doesn’t respond. When I cancel the clean, the FW update page pops back up. AAARRRRRGGGGGGGG!!!

1 Like

Looks like you aren’t the only one with that challenge. I admit > al* .zsolutely r2 problem. I noticed the update about an hour before a scheduled cleaning and tried it to see what would happen. No problem at all! I was very pleased with the results of the update, the most thorough cleaning pattern I have ever seen.

My update took longer than normal, but not 3 hours. I remapped last night and ran a clean today. Everything went perfectly, Knock on wood. :slight_smile:

I also had issues with the FW 1.6.130. I was wondering why it was taking so long. It took probably at least 30 min. I deleted the vacuum from the app and tried to reconnect it but it was still updating. Eventually I turned off the power by holding that button and then when I turned it on it said update succeeded.

@WyzeHongfei and @Rui, they should fix this beta FW 1.6.130 issue. Lots of people having trouble updating because it doesn’t tell you when it’s finished. Ticket 206850

1 Like

Interesting. Mine took about 30 minutes and eventually said succeeded. did nothing with the app or the Vacuum. Was waiting to see how long it would take.

1 Like

Yeah I probably was just not patient enough… Usually the vacuum updates haven’t taken that long so I thought it froze.

Same – I was ready to try something. But it finished and my mapping and cleaning went off without a hitch.

After 5 hours, it was still not done, and not responding to any commands. I restarted my phone, and the updating screen went away, but the robot still wouldn’t respond to commands. Thanks to one of your responses, I tried turning the robot off and then back on. It reported the update was successful (confirmed in the app), and it is now working. Strange.


That’s good you got it working again. I think it’s worth submitting a log. I submitted one.

1 Like

Sounds like the firmware update may not be confirming success. So submit a log if possible. Weird thing is I can still not see the x.130 update on my iOS, but that may be because they are throttling distribution to see if there are any issues.

BTW, if your update hasn’t completed by the time 10 minutes passes, be prepared to submit a log. Firmware updates should only take a few minutes.


Mine took a long time and when it was done it now tells me i’m offline. Any idea how I find the WiFi settings? How can I setup the WiFi

Mine never completed.

Had to press the Power button to turn it off. When it came back on, it said the update was completed and everything was good in the app.

1 Like

Was on vacay and the vacuum showed the available update, got home and the update disappeared?!? Why is this, I wanna update!

Possibly because of the amount of time it took to apply the update. A lot of s had issues doing the install, mine took about 30 minutes, others seemed to take hours.

1 Like

Thanks for your feedback, we have found the issue too on update and we are working on it


Thanks! Hopefully the next FW update goes more smoothly for us. :grinning:

Thank you!

Any updates?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.