Robot Vacuum Firmware Update Issues

Hi Wyze friends!

I am struggling with my Wyze Robot Vacuum and am looking for help brainstorming. Short version: I contacted customer support because I couldn’t update the firmware (it always showed as “up to date”, even though I’m still stuck at version 1.6.113). They sent me a replacement vacuum, I added the new replacement WRV to my Wyze account, and the new one is also stuck at firmware 1.6.113.

Here are the troubleshooting steps I have tried:

From Wyze:
1. Ensure the Wyze Robot Vacuum is connected to the charging station when attempting to update the firmware. Do not remove your device until the update is complete
2. Ensure the Wyze iOS app is updated to 2.16.48+
3. If using iOS 14 or later, ensure that Precise Location is ON and ensure Local Network permissions are on
4. Log out of the Wyze app, and then log back in
5. Force close the Wyze app
6. Factory reset the Wyze Robot Vacuum

Other stuff I’ve tried:

  1. Remove the old device from my account and start over (in case the two devices were messing each other up somehow?)
  2. Delete the Beta version of the app, download the regular version, log in/out etc.
  3. Delete all versions of the app, restart my phone, download and start over again.
  4. Delete map, factory reset, re-pair, …
  5. Download Wyze app onto another older phone (wasn’t able to use the latest version of the app this way, however)*

I also tried to get the Wyze app on an old Android device, unfortunately the app doesn’t show as compatible with this tablet due to its age. Has anyone else experienced anything like this? It seems like it must be related to my account and not be a software issue, which made me wonder if there was beta 1.6.113 firmware that might have accidentally frozen it in time… which wouldn’t be an issue but now I’m not able to add a replacement device.

I really love my WRV and would love to access some of the newer features that have been introduced since 1.6.113! I’m comfortable using the command line etc. if anyone knows how to flash the firmware manually.

~ KB

Hey, the newer firmware versions are only available to a select portion of users at this time. Your fully updated until the updates roll out to everyone.

1 Like

Interesting! Wyze support said the most recent version of the firmware was 1.6.202. I also bought my sister a WRV recently, and updating its firmware brought it to 1.6.202 as well. Do you know if there is documentation somewhere about this?

1 Like

The bottom is your current version, which is the last version that was rolled out to everyone normally. If you read the italicized text below the notes on the next 2 versions you will see that it’s not available for everyone at this time. Not sure why they are doing it this way, but eventually it will be rolled out to you.

Wyze support doesn’t always have the latest up to date information, you would have better luck here in the future in most cases :smiley:


Oh wow!!! I appreciate this so much, thank you for the information. :+1::nerd_face::+1:

1 Like

Did you ever figure out a solution for updating the firmware? I have 2 WRV’s that have the same issue. But one is stuck on 1.6.126. The second is stuck on 1.6.173.

I’ve been in the Beta program and I figured they would update themselves, but nothing has changed. And i’ve tried everything I can think of but no change.

I contacted customer support and they can’t figure it out either. And since they’re out of warranty they won’t do anything.

It’s very frustrating they can’t figure out how to push an update for me.

I feel the same way - it’s very frustrating! There are some other threads I’ve found where it sounds like they still intend to push out an update, but I’ll believe it when I see it.