Request binding failed

Just received my Robot Vacuum and it’s the first product I’ve been frustrated with from Wyze. To be fair, it’s the Wyze app, which I’ve never before had issues with until now.


  • Add Robot Vacuum
  • Press both buttons to reset wifi on vacuum
  • Hit next in app, taken to “Select your network”.
  • My 2.4Ghz network SSID is selected and I enter my password
  • Hit “next” and get the error "request binding failed, please try again.

Things I’ve done:

  • Turned off 4G on phone
  • Made sure Wyze is allowed Location Services and Precise Location is on.
  • Turned off 5Ghz network on router
  • Turned off 20/40 MHz Coexistence on 2.4Ghz
  • This same SSID is used for 10 other Wyze products (before I made all the router changes)
  • Reinstalled Wyze app
  • Password is simple 8 characters, letters only.
  • Full signal, I’m near the wireless router
  • Rebooted Phone
  • Rebooted Router
  • Rebooted Vacuum

Router: Netgear Nighthawk X4 R7500v2

I’m having the exact same issue and have tried the exact same steps. Very annoyed!

1 Like

Having exactly the same issue, my router is Google Wi-Fi (1st version). I also have a bunch of Wyze products.


1 Like

Service Status & Known issues

> **1/22/21 10:40 AM PT** - iOS users will currently have trouble setting up Wyze Robot Vacuum. Vacuums already paired with an account will be unaffected. We are testing an app update that will resolve this issue and we plan to release it in the next few days. Thank you for your patience.

But that makes it sound like a vacuum issue, which this issue is before even connecting to the vacuum in any way.

1 Like

So, reading the Zendesk thread I realized the issue is in the iOS App.

I have also an Android device that I can use. I did update the Wyze app before using it on my Android device and it worked.

After the initial setup (name, location, share, etc.) the firmware was updated (for some reason twice) but looks like it is working now.

The vacuum is even being listed on the iOS app, so looks like the issue is with the setup on iOS.

I hope it helps. Regards.


Sadly I have an iPhone…BUT my girlfriend has an Android so I’ll snag hers and try when she gets home. I miss my Android :frowning:


We have only IOS (same issue with new vacuum,) so I am download BlueStacks - an android emulator - and will attempt setup. Wife just keeps glancing unhappily between me and the vacuum.

1 Like

Bluestacks is a no go. the android emulator doesn’t see an actual wifi network, only a gateway in the app which accesses the wifi actually connected to the pc. Well, crap. This sure sucks. We’re an IOS family with no androids.

@scutshaw @allan.christian @dabluemel Good news. Wyze just announced on Facebook that the new iOS app is rolling out now, so it’ll hopefully be available on the iOS App Store shortly. Even better news (for me anyways) is that using an Android phone did the trick and we have a fully working super killilling, human destroying, cat terrorizing, dog chasing robot vacuum now.

1 Like

OUTSTANDING!! New update is here! I am past the failed binding and am connecting now. I have a Golden Retriever that REALLY needs to be chased.


I used my old android phone to set up the vacuum and it’s working fine now. It even shows up in my iOS Wyze App.


IOS works now.

1 Like

That was pretty cool. It didn’t work, then I went to this thread, they said an updated app was coming, they announced the new app (within minutes!), I downloaded that and it worked! Talk about bleeding edge, but it worked! Thanks!

Still having the same issue, even after the update. Looks like we had a tiny window of couple of hours to establish a connection and make the firmware update, as according to this:

I’ve seen the article and all the heads up about updating. I don’t understand what they say about "Update by 1/22/21

Are they saying if you don’t update the app and the firmware of the vacuum(which I can’t because I just got it yesterday and can’t connect to it) that you won’t be able to use the vacuum with wifi at all? Like the only option will be to just turn it on and have the robot clean the house on its own with no way of using it with the app?? That can’t be it…

No, it simply states that you must update the firmware and app, So if your app is up to date, it’ll prompt you to push the firmware up to date to your device. If you don’t push the update and ignore it, you won’t be able to control it via the app. Some people turn off automatic app updates, so it would be a problem for them primarily until they manually updated the mobile app

aanndd it’s broke again. Girlfriend is out of town for work now so don’t have an Android to test. So. Freaking. Frustrating. I got back to this point because I opened up Wyze and was met with “Failed to update device list (error code 2001)” so I figured I’d just delete it and add it using my iPhone now that “the issue was fixed”. Looks like other people are seeing the same issue possibly, but people fail to ever actually type out what their error code is in other posts so…who knows!

Got it. I signed out of the app. Deleting the app wasn’t enough because iOS apparently remembers enough and signs you right back in when you download it again. So signing out and back in (after having to update my password…) fixed the issue. Fully up and running, configured using iOS.