Remove Device from List (Thermostat)

Searched for a solution but couldn’t find. I can’t get through setup due to beta firmware issue, so I have a device listed but setup not completed. Since deleting device requires access to device, any idea on removing from list without access to device?? Thx!

You should still be able to delete the device even if it’s offline. You just need to select the thermostat, then settings, then you should be able to delete it. After you delete it, press in on the thermostat dial for 10 seconds until you see the reset option. You’ll need to do this before you set it up again(if you are setting up the same unit again).

Appreciate the suggestion, but it won’t get past Finishing Setup (see pic), so I can’t actually get into the thermostat…hangs on this step. I’ve tried different devices, press button reset, force shutdown, etc. It’s the beta firmware from last week before 1.1.2 came out. I’m getting a replacement from support, but I need to delete this from list.


What happens if you cancel setup and try to go the thermostat when it’s offline? Are you able to delete it. When a product is offline you should still be able to go to it in the app and delete it.

When I cancel out of setup process or force close app, and try to go into app, it just starts the set up steps again. See pic below. One thing I haven’t tried is a simpler system setup like heat only. I have 2 Stage heat and a humidifier on the terminals. I could try that and see if it gets thru setup. You can see in first pic that it doesn’t actually get to step to name the thermostat, still default name.

Updated: Nope. Simpler setup didn’t allow it to finish setup and access device. It’s strange to require access to device to edit / remove from device list. Is this going to stay on device list permanently? Not sure other options.

Try deleting the app. And reinstalling it. See if you can get to the offline device to delete it. You could also try the alternative setup so you’re able to delete it. I haven’t experienced this before, but I understand it is frustrating.

Cleared cache, then deleted app and reinstalled. Still listing device. What is the alternate setup process?

That was my way of describing:

What happens when you try to select the thermostat in the app?

This pesky thermo, lol. Is the thermo still powered up?

Or did you get the eecobe in place? I think I spelled that right.

Goes back into setup mode and starts over. And I’ve done that way too many times.

Goes back into setup mode.

YES! :face_with_raised_eyebrow:

Yes, but each time it hangs at same point then it either requires a cancel or shutdown app.

I returned it. The “3 lite” doesn’t handle humidifier.

I dug back into my pile of old thermostats and found a Proliphix IMT550W (long story) which I reinstalled. Full featured, but it requires browser access, and I’d prefer common app for all smart devices … so once warranty placement arrives, I’ll go back to Wyze.

But still need to get this current bricked one off Wyze device list!?!? Sorta think I need to do before sending back.

Appreciate all the help!

I wonder if powering it down might help? So when the app comes up there’s nothing to see on the network?

Turn off Bluetooth?

Just spit balling an order in my head. Some of these things you have done, but thinking of a full flush/disconnect

Remove power from thermo
Open wyze app go to Account and sign out
Force stop app
Clear cache
Delete all data
Turn off Bluetooth
Launch wyze app again
See if you can delete

Not sure if any of that will work, I wonder if it’s hung up on your “account” on the server side? Reminds me of the old citrix roaming profiles days.

Yup. That’s what I’m thinking. I have tried at varying times over last few days all of those option, but I do appreciate the spitballs.

Another option that I’ll try when 1.1.2 becomes available again…

Immediately after I kill the app once it’s hung up on Finishing Setup and if I look back at the device list, the cloud with a line through it goes away for a few minutes (see pic below). It doesn’t last very long, but I have noticed that on the firmware page it’s actually communicating with the server and shows active on firmware list. Once 1.1.2 becomes available again, I might be able to force the firmware update from current beta fw. But who know when 1.1.2 will be available again.

Here’s hoping.

I’m tagging the @Mavens to see if they have any idea on this one. Maybe you can contact support some time too to see what they say.

1 Like

Has there been any progress with this? I have the exact same problem as Marc. I really don’t want to try to install the thing or power it up another way. I just want to delete it. Can’t get to settings because it wants me to go through the setup each time.

Unfortunately, no. I just moved it to bottom of device list. Don’t see it unless I scroll down.

Ugh. Same.

No fixes yet? I have the same exact issue. I tried to reset thermostat and now have this issue.

Not that I am aware of…

Any updates on this? I just ran into this issue after replacing my modem/router setup.

Nadda. Hasn’t been addressed. Just move it to bottom of your list of devices. @Chuan