How do I remove thermostat from Wyze app?

That doesn’t work. It just sends me to thermostat setup with no option of removing the device.

How about the pencil in the top right, then edit devices?

Tried that. Doesn’t work.

Try going to the thermostat settings and go all the bottom of the section. There should be a delete button there.

I can’t get to thermostat settings.

Are you not able to complete the set up? Maybe just get all the way through the set up even though you’re not gonna use it, then you’ll be able to delete it from the app.

No I can’t. I’ve already returned the thermostat so I can’t complete the setup process.

Hi @GaryGold Suggest opening a support ticket keep track of the number until it is addressed.
You may have to remove the Wyze App, reboot the phone and reinstall.

1 Like

I accidentally swiped right on mine. We’ve got a date next week!



1 Like

Same problem here. I want to delete the thermostat (that could never complete its setup) and can’t.

I tried that, and everything else I could think of. The device setup is linked to your email address, so re-installing doesn’t help at all. We might have to start a new account with a different email address and re-install all cameras, locks, etc manually. This is a terrible software oversight.

1 Like

Sorry to hear you have same issue. I know this pain. What setup step do you get stuck on??

Here’s my journey …

Was a solution for this issue ever found? I’m having the same issue.

The first unit I received was defective and I had to exchange it. In the thermostat setup I’m stuck in the HVAC System section where it verifies the wiring. I can’t get past that anymore since I don’t have the unit and that was the step I got stuck on with the defective one.

So since I can’t get past set-up I can’t go into Settings to delete it. When I go into Edit Devices from the home screen it has the remove button but that just prompts me to go to settings for the thermostat which takes me back to the setup screen.

Nope. Not that I am aware of. I just moved it to bottom of device list and now don’t see it. Maybe someday….

Problem solved if you still have a thermostat. What i did is i used another secondary device. Signed up for the Wyze app and installed it on that device. Once the installation was complete, the thermostat automatically disappeared from my primary device.

Then i deleted the thermostat from the secondary device and it was now not attached to anything. I redid the whole installation procedure on my primary device and it went smoothly.

1 Like

I found a way to remove my outdoor smart plug from my device list! I also got hung up on a firmware update and would just freeze up and couldnt delete my device. I actually returned the device so i did not have it in my possession. What i did: i shut off my wifi, bluetooth and mobile network. Then i opened the device settings even though not connected. Once i was in the settings screen i enable my mobile data and it let me remove it. Hope it works for you.


I’m having the same problem. After over an hour in chat support, I was told this is an iOS issue. Very frustrating…

It’s best to just hide it at the bottom of your device list.

Thank you so much! THIS worked. It’s been years of looking at that useless icon.

1 Like