Person detection announced over echo speakers

Recently discover you can setup an alexa routine to have your echos announce whatever you want when a person is detected on my v2s. Works great! I also have the routine turn a light on and change color in case I miss the announcement.

Yes it’s the best. And you don’t even need to set up a routine to do it! But it doesn’t work for everyone.

Oh wow! Thanks. I’ll try that instead. I use an echo show 5 and echo. I see the echo show 5 has live view as well. Thanks again. I’ll remove announcements from my routine and just leave the light control. Report back if it doesn’t work.

Didn’t work but I’ll try again later. Maybe I have to wait for the cloud to update? I had disabled the routine I had for this to test. Maybe I should have deleted it? Put things back the way they were and all is good.

Not sure what you mean? I was just saying that the announcements work even without a routine if you just enable them at the Cameras level in Alexa devices.

Just did a retest. You are correct about just enabling the camera setting. On my echo show 5 it did announce but didn’t show a live view. I posted to the forum you sent me a link to that’s about this subject. I still like the routine because I can give it a custom announcement.

Ah, I see I just responded to you there. I don’t think pulling up a view is part of this announcement feature?

The person detection and announcement work great for me on two different cameras. The one thing I have noticed though is that there is not much of a time delay between reports. So for example I have a camera in the garage and if I start working in the garage the camera he is going to make an announcement every few minutes so I am looking for a way to turn that off. In other words I would like a delay before it can repeat the announcement. I know how to do that in the Alexa programming with a switch or motion detector but I don’t know how to control it from Wyze directly would appreciate any comments

I don’t think you can. You’re essentially asking for a “cooldown” period on the camera longer than 5 minutes. If your camera has CamPlus you can remove it and revert to legacy detection (if you have it) - that would get you out to 5 minutes. Or you could set an Alexa app routine to turn off power to the camera after the first announcement. None of these are very good.

You explained that well, thank you. But I see two things happening here. If I have a motion sensor in the game, it sees motion, and responds quite quickly. I get a message that there is motion. And I can build a time delay into the Routine to hold off on another message for as long as I want. That doesn’t stop the motion detector from working, it just stops the output from being processed to a speaker or output device. So really the need is only to have control of the message from the camera directly that it has processed a decision that there is a person in view. We shouldn’t have to turn off the camera or change our functions, we just need to kill the message reaching an output device for the interval we choose. Is there a way? It seems the camera message goes right through the system unchallenged! And it is annoying to have all these messages on the Echo speakers every few minutes. I would like to do the same thing that I can do with the motion detector, just delay processing of the message for a chosen time interval.

Have you tried suppressing the command? The setting is in the area where you set the times the routine is active.

1 Like

Well this gave me an idea that I could transfer the message from the camera which is “person was detected at Camera 1” through a Routine like you suggested and deal with it, but the idea resulted in two messages, no effect on the camera message going directly to Alexa. So I need to look in the Wyze app and see if I can turn off the message, although I like it, and substitute my own as your app suggests. I don’t want to turn off the person detection, just deal differently with the Wyze Camera generated message.

Well, I looked in the Wyze app, and I can’t see any way of controlling that message other than turning off the notifications which I don’t want to do. But in testing this out I came away with another experience. I covered my motion detector which is connected to this camera with a white plastic grocer store bag, just one layer to stop it from working but when I got near the camera, the message assigned to the motion detector (that black and white round item) played though Alexa. Another quandy, did the plastic bag not stop detection, or did the camera motion detection trigger the same thing as the motion detector does? If so I can use the motion detector for something else? Is the camera supplying the same motion advice as the motion detector?

Well to this point the long and short of it, is that I can’t stop the repeated messages from the camera person detection, so I have to think about that.

  1. Turn off the person announcements in the Alexa camera settings

  2. Create a routine where the trigger is a person detected on the desired cam and the action is a custom phrase of your choosing to the desired echo devices. Add a suppression time to this routine.

1 Like

Listen to @kjay. :slight_smile:

Also be aware that the self-contained motion detector has nothing to do with the person detection announcements. These are generated after (1) a Wyze camera detects motion through its lens and uploads a clip and (2) a Wyze server analyzes the clip and identifies a person and (3) the Wyze server tells an Amazon Alexa server (through the “skill”) and (4) an Alexa server communicates with your Echo speakers based on your account’s Devices, Camera settings and/or any relevant Alexa routines on your account.

So the cameras themselves and the Wyze app play very little part.

1 Like

OK, will I tried this, but hey I am paying for that AI, am I not? So you want me to turn off the Wyze announcement and substitute it with another one,
But these are not the only issues. I did the above, it worked, But now I seem to have created other problems. Like now I seem to be relying on the lens to detect motion. It was picking up trees on my front yard waving in the wind, So I narrowed the selected area to just the driveway, That worked until the sun went down. Then car lights turning the nearby corner went across the driveway and that was interpreted as motion, which triggered more camera recordings and warnings. So turned off motion to kill a multitude of warnings. I really just want to know that there is a person in the driveway, not worried about squirrels or car lights. It also seems I have turned of the motion detector eye through the bridge somehow. thinking of maybe associating that eye with a different camera?

The “motion detector eye” can’t determine whether it has seen a person move. Nothing in the Wyze cloud can determine whether that motion detector eye has seen a person move. The only thing that can determine whether it saw a person move is a motion video detected by a Wyze camera that has been uploaded to Wyze cloud for analysis. There is no association between a motion detector eye and any particular camera’s detections or videos. The fact that a particular camera powers the sense bridge is incidental.

So yes you will ALWAYS be relying on a camera lens when you are trying to identify people. PIR motion detectors don’t have that ability.

Also, you didn’t turn off the Wyze announcement. Both are the same mechanism - Alexa announcements triggered through the Wyze skill.

Well in my panic to stop so many videos and messages coming through everything I turned Everything off. So I hadn’t intended or thought that I would be turning off the motion detector. I don’t think I actually turned it off but I lost the signal through Wyze skills to Alexa and didn’t realize it for about two days. Space space so now I managed to get things working again tonight I had to go back seemingly and turn things on again and then on and then started to get copious videos again so I turned that off but I still have the motion sensor working I believe I have the motion sensor around the corner from the camera that is connected to so it serves a different purpose. The camera is telling me there’s motion in the driveway I really just want the AI emotion I don’t need at least I don’t need it in that position for the camera. However I can’t tolerate all the messages I get if the wind is blowing and the bushes move around and that creates a video and the car light at night going across they can find area of the driveway still generates another video. So I had to turn off the general motion part. It’s really a shame that we put all these good features on the cameras and then because there’s just not enough control over things and I seem to get the piles of videos. Time and perseverance will bring perfection I am sure