Outdoor cam blinking infrared lights

Hi I tried to set up this outdoor cam and got it to connect to the app. But then after the automatic firmware update I wasn’t able to connect to the camera. So I tried to delete the camera from the app and reconnect but now the camera just shows a constant pattern of blinking infrared when it’s on. I’m not able to add the camera on the app because I can’t get the yellow light to show up on the back to get into setup mode. Is this a now brick? It’s brand new! I’m at a loss. The firmware killed this new camera and wyze said I can’t get a replacement.
I tried to put a firmware file onto a SD card but I don’t think this outdoor camera takes a firmware from a card. I"m quite disappointed on this camera.

Edit: before troubleshooting too far, did you charge the batteries before trying the setup again? There’s a prominent tip about charging for 4 hours for best results. That’s the easiest solution to try:

Fully charge your Wyze Cam Outdoor before setting it up the first time. This can take up to 4 Once fully charged the light will switch from flashing red to solid red.
Wyze Cam Outdoor Setup

If that doesn’t help, it sounds to me like you’ve got a corrupted boot file, and the flashing lights you’re seeing are the equivalent of turning the ignition in a car, seeing the dash lights self-test for a second, then the battery dies and everything powers down. The car attempts another startup, then the battery dies again, wash rinse repeat.

Maybe obvious question, but is the power supply stable? Loose battery or wires maybe? Is there any chance you could test temporarily on wired power to rule out battery issues? I don’t have a WCO so I’m not sure. You may also be able to watch the voltage of the cpu when this happens. I’m suspecting that, at a minimum, the camera is getting stuck in a boot loop.

Battery powered outdoor cam???
Brick=yes maybe if cam was off line… :flushed: I would ask WYZE for a new cam since this information is very hard to find and does not come with a warning in the setup instructions as it should. If your camera was never finished setting up and was never on line when you deleted it you can flash the firmware with a 32GB SD card. see second link.

Thank you for your responses. I was afraid it would be brick. What a dumb design.