Wyze Outdoor Cam Hardware Issue

So, have an outdoor cam, base is set up and works fine, connects fine, etc.

Every time I try and add WOC, I turn on camera (it’s been charging for days yet still flashing red LED, which seems to be a problem) I get a flashing blue light for a few seconds then it flashes yellow twice which is when I try to sync it/pair it to base station.

I do not ever get the “Pairing in Progress” or whatever message I am supposed to get and the base flashes blue/yellow quickly (looking for sync) but WOC has no lights whatsoever.

Seems to me like the device/hardware is bad on the camera? Any other suggestions?


Welcome to the Wyze community @Birm!
Try flipping the little o/off switch on the back of the WCO off, then back on. Then try charging the camera. If that doesn’t work you may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.


I’ve definitely tried both of those things, and camera was charging for two days before I tried to do this the last time, still no go and LED is supposed to be solid red when fully-charged and yet never gets there.

I’m afraid I’ll probably have to hope for solid customer support/replacement device.

Definitely contact support with the information above!