Outdoor Cam battery won't charge and base station won't connect

I’m totally frustrated with my 1 year old Outdoor Cam and base station. The battery on the camera refuses to charge. I’ve tried every suggestion, fix I can find and still it won’t charge. On top of that my base station now refuses to connect to my. router. Just keeps flashing blue. Tried everything. I bought the camera in June of 2022 on Amazon so I assume out of warranty. At this point I’m ready just to throw it away and find a different product. I’ve had good success with other Wyze cams but not this one. I like the price of the Wyze products but can’t deal with the frustration. Probably done with them at this point.

Is the base connected via ethernet? Did you pull the plug for power and plug it back in after a few minutes? Did you power cycle the router?
How are you charging the camera with the power adapter or via the base?
I have been using the battery powered version one cams since 4 Nov. 2020 and I charge them with the 5V-2A power adapter that came with the cams, never tried charging from the base.

Base is connected to my Unifi UDM-SE gateway via ethernet. I tried changing cables and ports as well as unplug-wait-replug. I tried charging from both the base and a 5v-3amp usb power adapter. No luck. I’ve had problems in the past with the. base station connection but could usually get past it. Don’t recall having the issue with the battery charging. I use mostly Ubiquiti Unifi cameras with the Unifi protect app but wanted a cam for an area with no power or ethernet poe availability. I have regular Wyze cams and pan-cam in another house which work fine. I connect those to a Unifi UDR Wifi router which can run protect. Even though more expensive, I’m going to replace the Wyze cams with Unifi cams as they’re more dependable and I can record motion, etc without the cloud subscription. I’m not a fan of the Wyze cloud recording. Thanks for responding.