No QR code generating

my Wyze cams used to be so solid but now I have nothing but issues trying to login and now trying to setup my new v2 cameras. It doesn’t generate any QR code for me to even scan?!!

If you are correctly following the steps for setting up the camera (ie you tapped “I heard ready to connect” button), then I think I would try to delete and then reinstall the app.

I’ve had the same issue and tried reinstalling the app. It still does not generate a qrcode .

1 Like

What phone are you using and what version of software is it running. Makes troubleshooting FAR easier when we know what you are using.


I am using a Samsung S8+ and it has android 8.0. I’ve confirmed my home wifi is 2.4 qhz and not WEP. The QR code wont come up and keeps timing out. I did use my phones hotspot and it works to setup that way, but not home network. This is so frustrating.

This is what it looks like.

1 Like

In case others don’t see the picture:

I was going to ask if Emanuel forgot to post a picture; it didn’t display in Chrome, but when I clicked in the blank area under “this is what it looks like” it did open a picture.

Emanuel, if I understand correctly, you can set up your camera if you use the hot spot wifi, but not your router wifi.

If this used to work, what has changed? Are you using the same wifi router SSID/password as before? Is your phone connecting to the same wifi SSID as you are trying to setup your camera with? Were the cameras that worked different?

If you have admin access to the wifi router that doesn’t work, can you check to see if “client isolation” is enabled. That is a setting that prevents wifi clients (PC’s, phones, cameras, etc.) from being able to communicate with each other. It is often enabled in business guest wifi, but some home routers have it as a setting, although I would be surprised if it was the “default out out of the box” setting.

What type of home wifi router do you have, and what software is it running (stock or third party firmware, version of firmware.)

As you said, they used to work, but perhaps that was a v1 camera with an early version of firmware.

I know it is frustrating when things that used to work don’t work the same when you try to do the same thing.



Here is another topic with a similar problem. You may want to read it and see if it has any useful info for your problem.

<p style=“text-align: center;”> Thank you for the other topics. It was my firewall the entire time. I updated it and all is good now.</p>

Same here. Glad it’s working, but I also can’t figure out how a consumer firewall would be preventing it from working. Normally consumer type routers will let almost any traffic outbound, and then “related” inbound traffic. With that said, there would not seem to be much of anything that should require network connectivity in order to generate the QR code - Unless Wyze has something going on in the background (maybe a logon verification)…

I have no idea how it all works, but I do wonder if their app has something to do with a routers firewall settings. Before I updated my settings, the app would not log in either, I would switch to 4G and it works, but anytime I went back to wifi it just sat their with a blank screen.

I am not sure why direct communication is needed between the phone and the camera.

But it does raise a question about why the firewall security has to be lowered.

I always assumed (probably like oaktree) that the QR code was just the method used to allow the SSID / password of the wifi network to be loaded into the camera, since it has no other means to obtain without using the wifi. Amazon Echo’s and dash buttons enter into AP mode for setup, and your phone has to connect to it to provide wifi settings.

I have never tried to reuse a camera with a different Wyze account. I have changed what SSID/password are used, and I did not need to delete the camera when changing.

I wonder if Wyze is verifying that the camera is still associated with the same account.

Consider the case where a camera is stolen. Will the thief be able to re-setup the camera and then view all your stored cloud notifications associated with the camera?


Emanuel changed his firewall settings from “Max” to “Medium”. My guess is that “Max” was enabling wifi client isolation. But I suppose it is possible that it is doing something else.

We still haven’t determined why the camera and the phone have to be able to communicate before the QR code can be generated.

I received three new cameras today and expect to set them up this evening. I will monitor the appropriate LAN with WireShark and see what off site communications takes place before the QR code comes up. Like BuckEye, the only thing I can imagine is an account verification. I also have re-setup cameras to change what WiFi they connected to, but it was always on my account.

Last night I did a WireShark capture of all the traffic for setting up three new cameras and updating their firmware. It was getting last so I have not looked at the capture yet, but I will later today and I’ll let you all know what I find…

Well, I have looked at the WireShark capture, and about all I can tell you is that there is communications between the phone and, but I can’t tell you what was exchanged because (as expected) it’s encrypted. My guess is checking on the account - but that is only a guess.

I have had this problem twice. The first time I solved it by reloading the app. The second time, no matter what I tried, the app would not generate a QR code. I tried everything.

Finally I tried logging my phone into another wifi network (the one that I originally used to set up my first wyzecam. When I went back to the app, and tried again to add the device, instead of a blank screen, it asked what network I wanted to sign the device into. I entered the name of the new network and the password, and it proceeded to generate a QR code. Not really sure why this worked. Could be

  1. The app will only assign QR’s if logged into the original network.
  2. The device (wyzecam 2) remembered the original network that it was assigned to, even after multiple resets, and kept trying to sign in to that network.
    Anyway, you can try it.

Wyze Cam Pan V3 - I had the same problem. NO QR CODE DISPLAYED ON PHONE I disconnected my iPhone from my network and setup the cam using cellular. Generated the QR code and let me finish setup. Dont know why but that worked for me