no micro sd card installed in camera


I am a newbie. I set up my first camera in our garage.

When I try to playback what was recorded, I get a message on the app that says “no micro sd card installed in camera”.

I have a Sandisk 32gb microSDHC UHS-1 card installed. What am I not doing?

From the live stream, tap the gear icon. Then tap Advanced Settings > Local Storage. Do you see the SD card memory available there? If not, then the card may not be installed properly. Try popping it out of the camera and reinstalling. If you see it, then try reformatting the card using the Format link on that page of the app.

I put the Wyze 32GB MicroSDHC Card into the device. It would only allow one orientation.

Still does not find the SD card.

Did you insert the card until you hear a click? A flat finger doesn’t work. You need to use a fingernail or a thin blunt object. If it’s seated properly, when you push it again with the object, it should click and pop out.

I have done the same troubleshooting procedures and I still get the message “no sd card installed.” This camera has been working fine for a few weeks with the 32 gb sd card but now it is not recognized by the camera. Any suggestions?

Is this a brand new card or one that was previously working in the camera but now is not?

I would try to format the card on a computer using this tool:


SOLVED – I had the same issue yesterday. I was using the Sandisk 32gb class 10.
When I kicked off formatting from the camera/app, it got stuck and after that the camera stopped recognizing the sd card. I tried formatting fat32 using a Mac and a windows pc but it didn’t help.
finally, i downloaded the formatting utility from the Sandisk site and formatted the sd card using their utility which did the trick. The key difference in formatting via pc/mac is that the sd card shows 29.5gb available while the out-of-the-box the sd card is 29.7gb free space. Formatting using the sandisk utility gives back the 29.7gb which the Camera is able to detect.


I purchased a Wyzecam Pan camera about a month ago with a SD card from Wyze. The card didn’t work, so they sent me another one, and that didn’t work. It would say “No Micro SD card installed.” So the Wyze rep and I decided it was a bad card slot on the camera itself. So they sent me a new camera altogether. I had asked if they could test it first before sending it to me. He said they did. It arrived yesterday and both SD cards that I had didn’t work. I got the same error message. I hope when he said they tested the camera, that they tested it with a SD card. It would have been more ideal if they kept whatever SD card they tried in it (if they actually did try a card in it) and sent it to me even if it was the 3rd card I would have gotten. That’s because how do I know now if both SD cards I have are defective, as well as the card slot on the original camera? The only thing I did differently was that I upgraded the app on this new camera before trying it, so I don’t know if something was wrong with the upgrade. Also, could there be something in one of the menus in my iPhone that I need to change? I went through every menu. The operating system on my iPhone is version 10.3.3.

1 Like

Hope this helps,





Thank you for your reply. But I don’t really know what you and others are talking about when you mention things like Sandisk card and trying to format with a pc or Mac and then you downloaded a formatting utility from a Sandisk site. First of all, I have a Wyze SD card that I purchased with the Wyze Cam Pan camera. I expected it to work right away when inserted into the camera. I did go to the menu for Local Storage and formatting but it’s in that menu that it doesn’t recognize the card.
Concerning formatting the Wyze SD card on my MacBook Pro, I don’t have any port nor accessory that I can plug it into, nor do I feel like going out and buying something $30 or more or even a few dollars, when it should have worked right away in the camera. I don’t understand how it supposedly worked for them before they sent it to me, because I had asked them to test the new camera with a SD card before sending it to me. But even if they did test it, it was with another Wyze SD card they had, which they didn’t send with the new camera. So now I have 2 Wyze Cam Pan cameras and 2 Wyze SD cards (sent to me previously), all of which don’t work when the cards are inside the cameras.

1 Like

@heronshopnew Unfortunately, to get your Wyze SD card properly formatted to work, you will have to purchase an SD Card Reader to format it through your computer. Please see link below to one that works well and is quick. You can use it for future purposes as well if you want to transfer videos from the micro sd card to your computer. Works with standard SD cards as well as there are two slots. This card reader is $10.99 if you are not getting anywhere with Wyze on this issue. I didn’t bother to contact Wyze about this since I did not want to go through the hassle. The comments up there suggested formatting via computer so I went on Amazon to order the card reader, formatted it through my laptop, and it worked right away. (Mind you, before I looked this up and ordered the card reader, I tried several times back and forth between the Wyze Pan and the Cam to re-insert the card and format and that did not work no matter how many times I attempted) Hope this helps you or anyone else having this issue.


I think the link has changed. Try this one.
SD Memory Card Formatter

@johnbmudd. Thanks! I updated the link in my post.

JohnBMudd - I used the link downlad the SD Card Formatter program to format my brand-new microSDXC UHS-I Card Select 64GB and still shows the "No micro SD card installed in camera. I have the card inserted properly and it clicked into place in my Wyze camera.

I had a camera with similar symptoms. Ended in a return.

had a hard time as well. here’s what happened:

opened new cam, installed firmware update. inserted brand new sd card - it’s not recognized.
after every possible iteration of powering up/down, with and without the sd card, putting the cam on the network, taking it off, buying yet ANOTHER new sd card, format in pc as exfat, fat32, tried a known good 8g card, nothing was working,

i decided to change tactics. NO WAY was every sd card i was buying bad. in fact, idk if i’ve EVER had a bad sd card out of the package. EVER.

opened another cam box. DIDN’T upgrade the firmware. inserted sd card and voila. recognized and formatted. removed the sd, updated the firmware, reinserted sd - still working.

opened a 3rd new cam. no firmware update until the sd was recognized. opened a 4th cam box and followed the same procedure. worked like a charm.

the 1st cam with the firmware update still won’t recognize the sd. i’ll need to download a previous firmware version, load it on the cam, and try again, see if that works. if it DOES well…doesn’t mean for sure an update caused the prob, but makes it more likely. until then, i have a cam in place that can’t record locally. bummer.

now it’s possible the 1st cam just has an issue. sd slot could be bad. firmware update could have broken something. have known good sd cards, so that’s not the problem.

but as far as having to buy an external drive to format an sd? really???

all my cards are 64g btw

also wondering what s/w version the cam is running…if you had a card working and it suddenly stops, what changed?

1 Like

I’m testing the replacement cam tonight. I’ll try the sd card before updating firmware. Just in case that helps.

yes pls let us know how that goes

There were a few cams recently that were found to be missing a resistor on the board needed for the SD card reader to work. I would highly recommend contactin Wyze about a replacement camera.

Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, please file a Support Request. Depending on the nature of the problem, rather than use the website link, it is helpful to submit an App Log and/or a Firmware Log.

1 Like

Now I have three cams. Two are from amazon, my original & a replacement. Just tested the replacement and it’s unable to see sim cards. Just like the original. Including an official Wyze sim card.

The third camera is from Wyze. It works with all of my sim cards.

Now I have to go through the return process at Amazon again. I’ll have to leave a review to warn others. Not that there aren’t already reviews there warning about inability to see sim card.