New Wyzecam 2.0 and can't get "ready to connect\"

Have just received my Wyzecam 2.0 and I’ve tried following the instructions.

I plug in the USB, then wait for the flashing yellow LED.

After pressing the setup button I hear some clicking, but no voice saying it’s ready to connect.

I had a problem with my second V2 cam. It would go thru the setup and never connect. My first camera had updated the firmware the other day and works OK, so I downloaded firmware version, then updated the second camera via the SD card.

The instructions for flashing the firmware were in another post (search for ‘Flashing your WyzeCam v2 firmware’).

After that the camera worked OK. Hope this might help.

First try holding down the setup button for 20-30 seconds to do a factory reset. If that doesn’t work, then the firmware flashing instructions are here:



1 Like

I currently have WyzeCam Support Ticket #45445 submitted for this same issue. In my case my V2 WyzeCam will not go into a firmware flashing mode, so I’m pretty much dead in the water. Hoping to hear from support saying they will swap this broken cam for a new replacement.

I get the ready to connect and the app is installed on my phone but it never connects. Is there something else I need to do?

The link to firmware flashing instruction leads to a 404 page.

This is very frustrating. My Blinq cameras did not require this sort of procedure and your links should be current.

Firmware link here