New Wyze band not recognized in app

Just purchased a new band. However, it will not connect to the app on my Google Pixel 3XL. I have tried the Wyze support article troubleshooting steps to no avail. The 4 character code never appears in the app. Band is fully charged, tried rebooting the band, rebooting the phone, toggling Bluetooth. I haven’t tried a different phone yet, so am otherwise stuck.

I haven’t found similar issue posted here or elsewhere, so appreciate any assistance. Thanks!

I suggest you break out another phone and try to set it up.
I tried and tried to set the band up on my Samsung s9 plus to no avail The 4 character code never appears.
Fired up my old S7 , set it up with no problem, The 4 character code popped up quickly .
After you set it up on a different phone, then you want to open the app on the phone you normally use, be sure you have bluetooth turned on , on that phone.
turn off your Bluetooth on the phone that you set it up on, then go to the band and go to the find function and tap on that it should find your other phone and connect to it , then, you should be all set from there, this is all assuming that it will work on the other phone that you try.
We should not have to do this but ,that’s what I did to solve the problem.
Best of luck to you :slightly_smiling_face:


Excellent, will try that today, thank you for your suggestion! Will report back what I find.


I am having the same issue. :confused:
Update - In another thread about the issue it was mentioned that you have to have your location on.
That sorted it for me and it is up and running now.

After I charged my band , I found it would not connect back to my phone, turned on location and it connected right up.
Then I just went and turned location back off and it stayed connected to phone

1 Like