New V3 camera with permanent red light

Have a new V3 camera from Amazon, Out of the box, it goes to a permanent, non-blinking red light, that does not change after being plugged in for several hours, nor does it change when depressing the set up button. I sent Wyze support a notification of my problem, and they indicated to power cycle the camera. Have done that several times, allowing hours, not minutes, to reset itself, but to no avail. Every time I plug it in, it goes to an immediate standing red light, that does not change. After Wyze’s initial response, I have not heard back from them, so I am reaching out to the community, to see if anyone has encountered this on a brand new device, and if returning it is the only option. That’s all I want to know, thank you.

I believe that is the camera status light If the camera is otherwise working fine, you can turn that light off. Just go to settings, then advanced settings, There you can turn the camera status light off.

Solid blue the device is working properly, solid red device is powered on and initializing. Sound like it doesn’t want to setup to me.

Welcome to the Wyze community @aWintersTale!
If you’ve tried power-cycling and pressing the setup button, you may want to try flashing the firmware on the camera.
How to flash your Wyze Cam firmware manually
If that doesn’t work, try calling Wyze support.
(206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT


You bought it from Amazon so returning should be far easier than from Wyze, especially if a Prime member.

Solid Red LED can also mean a camera is streaming live too…

1 Like

Thank you for the recommendation. I tried flashing the firmware, and it seemed to “bump start” the camera into the set up process steps, where I now have a streaming V3 camera. Thank you for the help, and to the others who responded! The experience was pretty good, and I’m glad I did not have to return the camera to Amazon.


Name it “Roxanne”.

1 Like

I’m having the same exact problem. Really disappointed in Wyze’s products so far. But I totally deleted the device thinking I could just reinstall it. So I think I just need trash it and find another more reliable brand camera.