Need Help! Playback Delaying, Extremely Slow

So I have three cameras. All my cameras playback is extremely slow and not fast by any means. All updates are made. My phone is up to date. I have great wifi to all cameras. SD cards have no issues. So why is my camera playback so botched? I need help for this as I am trying to review footage but taking so long is proving a struggle as someone vandalized my car (In Plain site to my camera.) Never was picked up. But will pick up a bird flying or cars driving by but not when something In Frame, is occurring… Any help or advice please? I am desperate need to figure this situation out. I’ve already gotten through only 10 minutes of footage in a 30 minute span now.


Usually when live view or playback is slow or skipping frames it’s because of a WiFi issue. You can try switching from HD to SD or 360p quality and see if that increases the playback speed. I had one cam that didn’t want to stream at HD quality, but worked fine on 360p. I recently upgraded my WiFi and added a new access point closer to the cam and now I have no issues with HD quality.

If you’re missing motion events it’s possible they’re happening within the 5-minute “cool down period” after an event. If you get an alert because a car drives by then you won’t get another alert for 5 minutes. You can try adjusting the detection zone to exclude the road so you’re not constantly getting alerts for passing cars/pedestrians.

Because Wyze removed the decoder for Android in the last update. Screwed them totally up. Need to roll back to older app.

1 Like

You’re right, I hadn’t seen that issue at the time, but I see now the latest release of the Wyze app removed the hardware decode option for Android and that is causing delayed or stuttering video on some (mostly older) Android devices.

@CorpseMother, if the slow playback is recent it may be due to the missing hardware decode ability in the latest app. If this has been ongoing it may still be one of the issues I mentioned previously.

Please see this post from WyzeLi. :slight_smile:

1 Like

All I get when trying to install Android 2.5.82 is. I have tried downloading and installing several times with the same results:
App not installed.

The package appears to be corrupt.

You must uninstall the current app first. Then install the apk. :slight_smile:


Doh! I should have known that too. Been a long day!

That did work, now I don’t have the 15 to 25 secs delay at least when something moves in front of the camera. I could put my hand in front of the camera and 15 to 25 secs later it would then show up in the app showing my hand. Was having some playback issues that this solved as well by going back to Android 2.5.82 as well. Hopefully they fix this soon with the updated App.

Thanks! :slight_smile:

1 Like

Glad to help. :slight_smile:

1 Like

Good information. I was wondering why playback was terrible lately. So the temporary ‘fix’ is to uninstall the current app and go back to V2.4.82?

Yep, that’s your best bet , to rollback to V2.4.82 for now .
It Is unsure when the new version will be working better

Yeah, made mine work again. I could not have kept them if they worked like that after the update.

OK thanks. Will rollback when I get a chance. Glad you said ‘update’ not ‘upgrade’ :wink:

You can find the file here

Im new to this stuff. Could some one give a step by step? Also if I rollback will my past videos still be viewable on the memory card?

Sorry for the delay in reply. I see it has been a few days since you posted this. However, the rollback will not affect the memory card videos. You can still view those. If you still want to install the APK V2.4.82 make sure to uninstall the current version first. See the step by step installation instructions in my post below:


Horrible forum format.
When someone replies to a comment and you click on the “Reply” to show it you have to click on the Down Arrow in the upper right corner to reply to the reply. Idiotic!

Thanks for mentioning the App version. I just checked and despite regularly doing updates in Google Play Store, I’m at v2.25.22. Maybe because I have an older phone on Android 9 and can’t update to newer version due to age of phone. (OK, maybe I can find a way to get to a newer version of Android. Phone is long out of warranty.)

OK, so why am at Android V2.25.xx yet when I look at the app it says "Updated October xx, 2021?

Yet ANOTHER losey design choice for the forum. The “date” in the upper right is EASY to misread.

Oct. '19 in LIGHT “grey” “soft” lettering is difficult for these and other “old” eyes to read.

And NO ONE is focusing on the “timeline” even further to the right. We focus on READING the information we are looking for because we have a PROBLEM and are frantically trying to find a solution not sitting around perusing a forum and thinking “How beautiful does this look?”

The dates on the right indicate the date of each post in the thread, that is why when you scroll up or down you see the dates change