Lag in live view and playback from SD card - android app v 2.5.28

Good day,

Am I the only one experiencing issues with live view in SD/HD and with SD card playback ever since Android app v 2.5.28 was released?

With the previous version of the app - everything worked very well. The lag in SD or HD resolution was resolved by enabling the hardware decoder in the app settings. And there was never an issue with SD card playback.

With the arrival of 2.5.28, only 360p renders real-time, lag-free viewing experience in live view. However, SD and HD are even slower than they used to be - the seconds count moves only every 2-3 seconds. This time, the same also goes for the playback from the SD card. And the app no longer offers the hardware decoder.

I have several Android devices at home - the ones that were not upgraded still work well when the hardware decoder is enabled. The ones where I upgraded the app have become fairly unusable.

Anyone else noticing the same?


There have been numerous complaints with the new app version. I had to uninstall the new app and reinstall it before mine would even work. However, I’m not experiencing any playback issues like you mentioned. Actually mine are working faster with the new update. This new release has a few bugs that need to be worked out I believe.

If you want to go back to the previous Android app version until this new release is more stable, you can download here:

Android Previous App v 2.4.82

I believe some of the issues are with the removal of the hardware decoder option, but I dont think the lag problem is with the app or cameras itself, it is with whatever the hardware decoding was making up for because mine still stream just fine without it.

Not sure, but I have the same problem now. It’s pretty much useless now.

1 Like

Sorry just read the article again. My problem is with playback. Playback is now useless on my cameras.

1 Like

I was having this problem as well with v2.5.28, and after the update today to v2.5.30 the problem seems to be even worse. It is almost impossible to watch any playback, and live streaming is in slow motion with an exponential delay the longer you watch?!

I did a full uninstall and restart of the phone. Problems still persist . . .

I was hoping they would have at least corrected the problems with the IR switching at dawn and dusk, but that hasn’t been addressed either.

I uninstalled the app. Turned phone completely off. Reinstalled, Was hoping but no good. Can I go back to the previous app? This really stinks!

1 Like

i got the same issues reported here.

My goodness. Worse today. Now all playback is in slo motion! If you try to record the event it records another time than what you are actually looking at! This needs to be fixed soon or I’ll be force to go with another company. My home was broken into August the 19th and I captured the entire thing and sent it to the police. Now my system is useless. I have tried it on 2 different phones, same result. Makes no sense more people aren’t raising hell about this.

I actually reported this to support immediately upon noticing it. The reply suggested I should test my network speeds and signal strength. Not sure - maybe I did not explain it well when I stated that I doubted it had anything to do with my internet speeds, given that everything worked fine until the app was updated.

I rolled back the app and disabled automatic updates on all my phones.

forgive my ignorance. How did you roll back the app?

Hey @roachone :slightly_smiling_face: It’s not hard to roll back to a previous app for Android.

  1. Uninstall current app.
  2. Install the previous or last working app version.

The link to the previous Android app is in the Post #2 in this thread.

So you have to install APK in order to install an older app?

You only have to download and install the previous app version no additional installation. Only takes about 5 minutes. :+1:

I appreciate your help but I don’t see how to do that without downloading APK. Would you mind putting a new link here so I can see what I’m doing wrong?

I went back to the APK website apkpure, and I told you wrong my apology. :pensive: It looks like you do have to download the APK file first. Then install the app version 2.4.82. Others have successfully made the install without any issues. I hope it works as expected for you. The additional step should only take a few minutes.

Download APK & Wyze App

Just chatted with Support, they are aware of the issue and gathering information for a fix. Their only suggestion was to keep the stream at 360p for now. Very frustrating. Rolling back the app works great, back to having the hardware accelleration option on Android and video is very smooth.

re Hardware Decoder option removal

Hi –

I understand (and agree with) your frustration, IMHO
Wyze Leadership forgot to pack their box of common sense when they moved across the street…

Here’s my suggestion (ask if questions):

  • ensure Google Play Store auto update is off
  • download old version 2.4.82 from weblink (it’s just one file that ends w/ .APK – Android Package Kit – similar to .EXE)

  • uninstall current version
  • install old version 2.4.82 from downloaded location (temporarily allow Unknown Sources)

My account is new so replies may be delayed