My WyzeCam just quit working (no power)

i got a wyzecam back in september, WyzeCam Pan. its been working great on the same plug, same cord and same power supply since then. i came home tonight and it was off, so i replugged it and still no blue light on the front. i pulled the camera and tried another plug, cord and outlet, same stuff. i even tried plugging it in to a working camera USB port and nothing. has anyone had any experience with this happening? Also, it is an indoor only camera, has never seen the outside or anything like that. also, the plug its plugged into, everything else is working on that. Thoughts, suggestions, comments? I dunno what to do and i already emailed support about it.

Here’s the connectivity troubleshooting guide:

https://support.wyzecam.com/hc/en-us/articles/360012903431-Connectivity-issues

If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support ticket, preferably from within the app while the bad camera is selected. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

1 Like

i did immediately submit a ticket. i looked at that troubleshooter and basically it said contact support, so i did. i just wondered if anyone else ran across this problem or experienced anything like this happening.

I just had the same issue. My Pan Camera stopped working. At first it gave me the “Power Cycle Error Code -90” but when I unplugged it (for 15-20 seconds) and plugged it back in, I got nothing. No LEDs, no clicking sounds, no spin, no anything. I exchanged cords with some of my other cameras and they all work no problems, but the pan cam is dead in the water. Did you ever get it resolved, I tried the trouble shoot option but had to contact support and its memorial day weekend so I doubt I will hear back from anyone anytime soon.

1 Like

resolved, yes. they replaced it for me. after i got the replacement, they didnt want the dead one back so i took it apart to see what happened and the power cord was disconnected. once plugged back in, it worked fine. after a while though, the power cable broke, which i believe was due to the over-rotation problem. i submitted all my findings to them in hopes of a better solution for everyone other than a replacement camera. i would suggest contacting them asap.

I bought the wyze cam in us. They dont operate in my country. I am having the same issue that the pan cam just wont work. It had a loose power connection and it used to rotate and shut off so I sort of jammed it and it started working . Now not even that . I am thinking of taking it apart. Any suggestions

I have three Pan Cams with this problem. If I spin the bottom, the camera powers up again. It works for a day or so and then down again. Has Wyze addressed it?

I too am having this problem. I’ve just now submitted a ticket. I will update here as soon as I find out from them what’s going on.

1 Like

I’m having the same problem. My V2 works as long as it’s connected via USB or to a power outlet. As soon as I unplug it, the feed stops. What am I doing wrong?

Welcome Sofiane. Your v2 has no battery. Your v2 cam requires constant power from the USB cable. Without the USB, your v2 cannot function.

Hmm and I thought it was wireless or did I miss something?
Thank you

1 Like

You’re welcome. The v2 (also v1, v3 and pan) cam’s data communication (security and video transfer) is wireless, power is not.

Same thing just happened to my Wyze Pan (Memorial weekend 2021). No power, I tried different others and plugs. I’ve had it for a few years. Guess i need to order another. I wonder if this is just the life cycle 3-4 years.
Hope they make a Pan camera for the outside.

Same here, its just dead.
Simple answer, these cameras are cheap chinese quality, and simply dont last longer than a year or two, if youre lucky.