Multiple motion sensor in same room and IFTTT

Hello everyone

I have two motion sensors in my kitchen. I added a second because while I’m doing dishes the single motion sensor would timeout / clear, and turn the lights off. When one of the two detects motion before the other the lights go out too soon from the first sensor clearing. I hope that makes sense lol. Initially I named them different names, hoping that if one caught motion it would override the other one and extend the duration that the lights stayed on. This didn’t seem to work so then I tried naming them both the same name. Even though they share a name they show up as two separate device in IFTTT.

I am not using wyze bulbs

Can anyone think of a way I can have one override the first trigger motion detection. For example if motion sensor 1 is triggered before sensor 2 then the lights timer will start again.

I think I got it figured out.
After grouping the two motion sensor together in the Wyze app it seems to be doing exactly what I wanted.


Have this same issue in the bathroom. One sensor placed in a way to catch the shower and the toilet will also get you walking by in the hall so I have to use two. Glad to know you can group them, thanks!

So how did you get it to work exactly? I’m assuming you have a smart light switch. I’m trying to do the same thing but in the bathroom. I have a sensor when I walk in and also a sensor in the shower to turn on exhaust when taking a shower. But when the walk in sensor becomes clear, it turns out the lights while I’m in the shower. I only want the exhaust to turn on when I’m in the shower and keep the lights on at the same time. This first sensor controls the lights and the second Controls the lights and exhaust fan. Hopefully it makes sense. What do you have controlling your lights, Alexa? That is what I have.

I have a similar circumstance in my garage. Obstructions require that I have two Wyze motion sensors for one Wyze light switch. I am using the same rule instructions for each - turn on switch when motion is detected and turn off switch when clear for three minutes. The set up does not always work even though it seems motion should have priority over clear. I have grouped the two motion sensors as @barry_henthorn suggests and will test that set up. I’m using Wyze app rules for both sensors. I’ll report back…

@rlowder131 , please report back. I still have not been able to get it correct. I will be waiting to hear how your’s worked.

Tested this over the weekend and no change. Grouping the motion sensors did not change how they function.
I also tried disabling the “clear” trigger on Motion Sensor #1 and the switch would not go off even if I made motion on Motion Sensor #2 - which verifies that Motion #2 is not taking over control of the switch until after Motion #1 clears and shuts off the switch… then Motion #2 will take over but only after I’ve been in the dark for a bit.
Any other suggestions?

I just reread @barry_henthorn instructions and I realize I did not name the sensors the same name. I’ll try that… but I’m also curious that @barry_henthorn states that IFTTT sees the devices separately. Where in the Wyze app are you able to set up the sensors with IFTTT? I don’t see that feature. Thanks.

I didnt think could name them the same?

Well… now I feel a little silly… re: my previous question about IFTTT… Of course IFTTT is basically the Wyze Rule(s) or Alexa or Google set up to trigger the device.
I realize that @barry_henthorn is classified as the solution but I cannot get his to work. I’m curious if @barry_henthorn is using Alexa or Google for his IFTTT or if he’s using a Wyze Rule. I have tried grouping the motion sensors and have tried giving them the same name. (to @Inf_2 - yes, you can name them the same… you just can’t tell which is which once you do). I have done extensive testing. The motion sensor that activates the switch (due to motion) is the one that has to clear to turn the switch off and the other motion sensor has no affect on the switch until the IFTTT function has completed for the first sensor. Based on my testing the switch can’t be “turned on twice”. It must complete the IFTTT full cycle (on and off) before the second motion sensor has any affect.
Thus, I’m open to some insight - what am I missing and what else should I try. @barry_henthorn I would love to know how you get the switch to basically “turn on twice”. Thanks!!