Micro SD Card goes to Read Only mode after 2-3 use

Bought Sandisk micro SD card and it worked fine for continuous recording. Once the size was almost full, I tried formatting from the Wyze App. The sd card worked fine and was recording continuously. But, again when I tried recording, it says operation failed. Now, the card is not continuous recording, nor it is allowing me to format.

I, then remove the card from camera and plugged into my laptop and tried formatting, it says the disk is write protected. I have tried every possible steps available on internet but in vain. I still have old recording on the card but it can only be read. Please help!

Hi, @shresthabezil. Welcome to the forum! It is very possible that you have a bad SD card on your hands. Also, it isn’t necessary to format your card. Once the card is full, the camera will loop back and begin to overwrite the oldest footage first and roll forward.

What size and where did you purchase the MicroSD card?

There have been several users reporting that the Sandisk cards fail to work consistently in their cameras and are more prone to failure. Some have actually found that their cards were not genuine but fake. This could depend on where you purchased the card like EBay, Wal-Mart, and Amazon.
If you have a different brand card on hand, I would test it and see if it works any better. I started using Samsung high endurance cards which are especially designed for video cameras. Additionally, Wyze microSD cards has a 1 year warranty if it fails they will replace it.

Here is some more useful information on formatting MicroSD cards from the Wyze support pages.


Was this a new card? I had this happen to me once on my phone, and I think it was because it ran out of reads/writes. This could happen with a cheap card maybe.

Thank you, yes it’s from a cheap chinese market at my place. Biggest mistake, should have opted for wyze one or genuine. Lessons learnt. Thank you for prompt response.

1 Like

You’re welcome!

Strong recommendation. Get a High Endurance card. Use in a camera results in A LOT of write operations. The High Endurance cards are designed for that type of operation.

1 Like

This can still happen with the wyze SD card. Mine did this exact thing once I deleted footage from it then the camera would not recognize the card but since it was a wyze SD card I just sent it back to Amazon and they sent a new one next day.

I am using quality Silicon Power micro SD that I purchased from Amazon. Two cards are now locked in Read-Only mode and I tried to clear the readonly attribute to no avail. I pretty much tried all the methods found on the Internet and still could not reformat the cards. Windows 10 is telling me that the cards needed to be repaired. However repair cannot be performed while the card is in readonly mode. So I am stuck. By the way, I only remove the cards from the Wyze cam when power has been removed.