Memu AND Bluestacks problems - help with either, please?

So, I have been successfully monitoring my 14+ wyze cams for many months now at my home desk on a PC monitor using Memu with TinyCam Pro - and it’s worked fine for months. Recently, the Memu home tab generates a popup advertisement which takes focus away from my TinyCam “tab” where all of my cams are normally visible - and this popup advertising prevents me from continuously seeing my cams.

Anyone else confronted with this recent STUPID Memu imposition? It’s so bad that I have to click my Memu “Tinycam tab” after each advertisement cycle where Memu has reverted back to it’s “home advertising tab” every time a new popup happens which annoyingly is about every 30sec to 1 minute. It’s to the point where I can’t continuously monitor my cameras at all.

I have a completely different problem when trying to use Bluestacks instead of Memu. In Bluestacks, I can’t download TinyCam pro from Bluestacks’ Google store because it says “I’ve already purchased” it. I can search the Google store and SEE the TinyCam Pro app, but the store only presents me with a “purchase now” button and won’t ever present a “download now” button [since I already own it]. I even tried to re-purchase it, but I get an error saying I already own it, then the Google store only will re-present me with the buy-it-now button if I search for it again, Wash-rinse-repeat.

GRRrrr! And, no - I don’t want to monitor my cams on a tablet instead. I’m QUITE frustrated with this recent turn of events.

Anyone got any suggestions or fixes for either problem? Please help?