Lock gateway disconnects every 2 days. Didn't do this for the last year+

My Lock gateway disconnects every 2 days.
I have had the two up and running fine for more than 1.5 years. Nothing has changed and the Wi-Fi bars are full. Flashing red so I have to unplug and plug in the gateway. Works fine for a couple of days then flashing red again.

I eliminated the signal quality, battery life etc. Seems to be a Wyze gateway issue (or latest firmware)

Anyone see this too?

Have you power cycled your router in awhile?

Anything new in the space that could be causing some interference?

I saw this sometime ago, almost the exact same frequency. My resolution was replacing my Internet Providers Router with a more up to date device.

This also solved an issue with the Wyze switches not staying connected and the Wyze Robot Vacuum disconnecting twice a week.

Since I have had no problems.

I spent months diving into router logs, configurations and tracing, working with my ISP and Wyze Engineers.

My ISP pretty much gave me the “sorry sir, nothing more we can do”.

Wyze kept working with me, but I eventually said thank you for your efforts, I’ve spent more time on this than it costs to replace the router and did, poof all issues gone.

Not sure if this could be something you could try but if on rented devices ISPs do push updates unbeknownst to the customer.

Thanks for the reply and suggestions.
I tried cycling the router - no avail.
Moved both gateways to a new location - still happens,
Door gateways (2) both show very strong WiFi signals.
I have 5 Wyze switches too and some are further from the router than the gateways. The switches don’t go offline. Neither do cameras that are 50+ feet further so router signal power is quite strong.
Since both gateways are showing this - not switches or Wyze cameras - it seems to be isolated to the gateways.

Still happening.
I also got a new router (not for this reason)
4 bars Wi-Fi strength showing on the app & > 70% battery on the lock itself which is 10 feet away.

Monitoring internet flow I see these being accessed: