Keypad PIN not recognized

I replaced my Wyze hub yesterday. The previous one was defective. Everything works as it should except when I try to deactivate an alarm from the keypad I get an “Incorrect PIN” message. I am using the same procedure and PIN as I always have. I have taken the batteries out to reset the keypad. I have deleted and added back the keypad. I went into settings and tried to reset my PIN to what it should be and the message says the PIN has already been used. So I know my PIN is correct. I do not want to use a new PIN. Any ideas?

I am wondering if the Key Pad might have a bad button that isn’t registering a press and therefore is transmitting an incorrect PIN.

Do you have any additional keypads installed?

Have you tested this by adding an “Additional PIN”. You can delete it later, but it will allow you to determine if one of the numbers on the keypad isn’t working. Using the 4 numbers you already have as the primary PIN (or less if you have a repeat #), let’s say 1234 as an example, you can set 1111, 2222, 3333, and 4444 as additional PINs (again revoke them after the test). If all four of your digits work, then it isn’t the Keypad keys.

Also, have you tried new batteries or a Factory Reset (Press and hold the reset button until the Home button flashes 3 times, then becomes solid, then all the lights on the keypad flash then go off… About 10 seconds) with new batteries before a new Setup?

Thank you for ideas. I only have one keypad. I set several temporary PINs to test the buttons and all buttons were working. I reset the keypad. None of this worked. I did all this yesterday. Today, however, the keypad is working properly and recognizes my original PIN. I have no idea why it starting operating properly.

My guess is it needed a breather to fully sync back w\ the HMS, although it shouldn’t. Either that or you chased the gremlin away! Glad you got it working.