Interior wall not seen as wall

Help Wyze. Significant issue with dividing rooms.

We have an open concept area where the dining area is contiguous with the living area, connected to the entry, connected to a hall that connects to the kitchen… which connects to the afirementioned dining area. (Think donut with the hole that is walled and has a central bar/kitchen sink, dishwasher and pantry…]

Well, when it comes to dividing this combined area, the app does not recognize the central walled bar/kitchen pantry… as a “wall”. Thus, I cannot divide the largest portion of my home.

Without artificially subdividing with virtual barriers, (not sure this will work] how can I divide my room up!? My guess is that this rquires an app fix.

BTW - if this is not planned to fix, I might as well return the vacuum. Sorry, this is a deal breaker.


Yes. Would certainly like to be able to define rooms using interior walls.

I have the same issue and only mapped half of my house into 2 separate rooms. This is a real bummer. Please sort this out.

I have a similar situation. I need to be able to split a large room into 3 different “rooms.” This currently isn’t possible in the user interface as it does not allow room dividers to be anchored to inner walls.

I don’t have an issue, but I split join rooms and then split across door openings. was wondering if you can post an image of your mapping and where you would like the split.

In the past I worked with @Rui on Vacuum issues. Maybe if you post the image and explain where and how you want to split the room, they may be able to help. I will also look at what you want and see if it maps to how I did it within my in-laws house.

I wish I could split across door openings. Here’s a screenshot of one example in my home. There are actually 4 doorways in this image. However, each doorway touches the inner section of Room 1, shown with dark grey lines.

When I try to split this room I can only move the 2 white circle targets onto cyan green walls, not anything colored dark grey. And I need to be able to lock a white circle target onto the dark grey walls in the center of Room 1. This would let me split this space into the 4 separate spaces it really is (a closet, bathroom, small laundry area, and hallway.) I’m using:
Vacuum Firmware 1.6.113
Android app 2.21.26, last updated 2021-06-15


My Vacuum FW is 1.6.130. I was fortunate to be able to load the .130 FW.

So the area in the middle is actual rooms and not an island. Here is a stupid question as I had weird results when I updated to a new version of the FW. Did you clear your map and remap your house? I missed it when it was mentioned in one of the posts. once I did that, the map was much better and Vacuum worked. A quick map should work. I am checking against my In-Laws home where they have some interior walls, but not sure if they show up as Dark lines.

@Rui , given the provided map, could there be an issue where the mapping thinks interior rooms are consider similar to islands and not actual rooms?

The area in dark grey is not an island but interior walls (ceiling to floor that contains a sink & counter in the bathroom + a sink & counter in small laundry space + closet shelving).

I just did a Quick Map today and ran into not being able to split rooms as shown above.
My app shows I have the latest firmware (1.6.113).
Thanks for trying to help.

I’ve had the same issue with no fixes. In fact, 8 of the 9 homes I’ve lived in since being a teenager have had the same issue- central walls with open halls or doors. (I’m 66 now.]

I found a workaround. I set a sheet of plywood as a fake wall between the inner wall and the outer wall. After remapping. It allowed me to use the inner wall for dividing. Oddly, upon removing the plywood, the robot goes through that “wall” to access rooms behind it.

@mainstreet1612, I’m not totally following you. Given your screenshot, where did you put the plywood? I have a similar problem, where it somehow thinks the area on one side of an interior wall (our bedroom dressing area) is the same room as the area on the other side of the wall (the guest bathroom and the hallway it opens into).


I placed a sheet of plywood between the red arrows when I remapped the house. (Between dining room and kitcken).

After mapping I took the plywood away.

Anyway, after the remapping it then recognized my central wall as a wall and allowed me to divide the large area using it as a wall.

1 Like

Is this verified to still be unresolved? I am still getting stuck trying to get my main floor properly mapped out because of the center “donut hole” situation. The central area of my main floor is floor to ceiling walls where the stairs are, but I cannot map to it and when I try to get the machine to just go clean the Front Room it gets stuck ramming itself against the central “donut hole wall” as it tries to go through what it seems to think is an obstacle and not a wall. It is frustrating this is still seemingly not addressed.

@Rui @WyzeDongsheng

1 Like

I have not re-verified it since discovering it and trying to get support to resolve or commit to resolve it. 'Seems it is still there.

There is quirky workaround that works in my house.

In between one room/space and another, (Between kitchen and dining room.) I places a panel of wood that would look like a wall. It mapped it ok AND also allowed me to use the central wall to divide areas.

With panel removed, the vacuum respects each area. Oddly, to enter the area behind the phantom wall (my dining room). It goes around. But on returning to base IT GOES THROUGH THE PHANTOM WALL(to the kitchen)!?

My phantom wall is in red below between the kitchen and our dining room.

Good luck!

Hi, I’m not sure if this is the exact same problem that some of you are having, but I have the same outcome from what appears to be a different cause.

My floor plan would appear to be correct, except certain rooms couldn’t be split apart as you’d expect. The app gave that “must be an exterior wall” message. In addition, sometimes the vacuum would try to get to the living room by driving through the bedroom closet, which obviously doesn’t work.

I really studied the map it drew, and realized that when it mapped the room containing mirrored wardrobe doors, it was seeing the mirrored reflection as an extra part of the room. In other words, if the room (a small dressing area) is six feet deep with a wall of mirrored wardrobe doors along one side, the vacuum seemed to think there was another six foot deep room on the other side of the wardrobe doors. This seemed to be the cause of all the problems I was seeing.

To solve it, I took a roll of butcher paper and temporarily covered up the bottom of the mirrored doors, then had the vacuum remap the area. This time, the extra six foot deep area was gone, the formerly gray areas of the map were now black, rooms could be split apart, and the vacuum now knows it needs to go all the way around to get to the living room.

Just thought I’d mention it in case this is what’s happening to some of you. Good luck!

Thanks, I guess I will try this approach and see how it goes. I should be able to do the same thing you did without a problem, although it seems like a proper fix is still warranted! Thanks again!

I also have a “donut” situation resulting in the vacuum trying to go through an interior wall. I did a hard reset, moved the charging base, and remapped the floor. The problem persisted. Placing a “no go zone” in the interior wall also did not help.

Is there someplace that an official fix trequest can be voted up?

1 Like

There really needs to be a fix for interior walls. I’m going to try the plywood thing. It is really frustrating for probably a simple update?

Did you try putting a barrier somewhere around the donut to “un-donut” it? This technique has worked for a number of folks on here.

As for the “official fix request”, the “wishlist” is the name Wyze uses, and all issues related to mapping get plopped into this thread, which you can click “vote” on in the top left corner: Wyze robot vacuum - map editing & enhancements