I think my Wyzecam V2 just died

It was working ok and when I just checked it, I got the error 90 & to power it off/on. Did that, no change. So I deleted the camera and tried to set it up. I pressed the bottom button, but got nothing. I then moved it to another power source, still nothing. I’ve had this for about 7 months w/o issue and have 3 other Wyzecams that are working fine. I’m thinking this camera died, but thought I would ask if anyone had an idea? Thanks!

Have you tried changing the USB that is powering the camera?

what is the warranty on these?

I found this by searching the Support section (top right on this page):


1 Like

Yep. I put in an email regarding warranty, so we’ll see what’s up with that.

If you have a SD card in the camera try removing it and then setting the camera up again (press the reset button on the bottom of the camera.) If that does not work try flashing a earlier version of the firmware (https://support.wyzecam.com/hc/en-us/articles/360009490871-Camera-firmware-flashing-instructions.) If neither work, then I’d look at returning it.

Just wanted to report back that Wyze replaced my camera. I think there may have been a short in the cable (the one they supplied) as the camera was dead and even when I switched out cables/USB power it was still dead. Up and running again though.