I Need Management Help – Latest Wyze Ticket 988235

I Need Management Help – Latest Wyze Ticket 988235

Since I have been told by Wyze support that there is no way to escalate an issue to a higher level I would expect that using the forum would do so.

  • All of my Wyze devices no long work.
  • Three of the devices were replaced by Wyze and they also fail.
  • Support really has gone out of their way to try to help but
    • When I try to define a device Wyze software tried to use the wrong IP address.
    • They offer to call me back in a few days and never have.
    • No replies to emails back to people requesting information.
    • Many of the support staff do not understand an IP address.
    • I have suggested where in the code the problem exists.
    • I have run the Route This software for Wyze. I even ran it with no other internet traffic while trying to define a Wyze device so that good sniffer software would have all the IP information.
    • I have suggested how Wyze could easily test my issue in about 15 minutes with their devices and it has not been done.
  • It’s been over 3 months and still no solution to defining devices.
  • The issue I have probably fails on all Wyze devices.

I would think if Wyze devices can easily be bricked by simply moving them to a new network with a different IP subnet address then this would be a serious issue. I get the feeling that the internet connect code was written by a contractor and thus Wyze knowledge does not exist about this code.

I was a systems troubleshooter for IBM, JD Edwards, and Oracle for 45 years and also worked stress testing systems to find issues. Because of my background I have a relatively complex home internet system with the ISP modem on the normal 192.168.1.x subnet. I also had a VPN router with a much stronger wi-fi signal at IP address (Note that something other than 1 is used for both the subnet and device address to make hacking far more difficult.) Because the wi-fi signal is much stronger on this router which used the 4 subnet all my devices accidentally got defined to the 192.168.4.x subnet. It made no sense to use this subnet to control a Wyze device and have the signal go 1000 miles back and forth when the device is local. When I try to define a device to Wyze and the ISP modem on the 192.168.1.x subnet it cannot connect to the internet because the Wyze device is being assigned IP which is trying to connect to a router that does not exist.

Are these Wyze devices connected to a 2.4 GHz network?

Hmm, I would delete the devices from your application, then perform a factory reset on your cameras. Then attempt to add the cameras to the 2.4GHz SSID that is associated with your 192.168.1.x subnet. The cameras do not remember IP addresses as they are assigned IPs via DHCP.

Could be wrong but doesn’t the DHCP (Dynamic Host Configuration Protocol) dynamically distribute IP addressing and configuration information to clients?

Wyze send out a UDP DHCPDISCOVER packet and the router responds with a DHCPOFFER which includes (but not limited to the) Subnet Mask, Default Gateway (Router) & Lease Time.
The client responds to the DHCPOFFER by sending a DHCPREQUEST.
The DHCP server responds to the DHCPREQUEST with a DHCPACK (acknowledge)

The router provides:

  • IP Address
  • Subnet Mask
  • Default GatewayOther information can be provided as well, such as The Domain Name Service (DNS) server addresses

ref: 4.1 Constructing and sending DHCP messages

Yes, using 2.4Ghz, deleted Android cache, deleted Wyze app, deleted account, and run the add device Wyze app with only the ISP’s router active on the 192.168.1.x subnet which the Wyze app detects, but the details of the device I am attempting to add in the network screen has the name of the ISP’s sspid but an IP of which subnet does not exist.

It must be getting from the ISP’s router (cache or corruption). Power down the ISP router for 10 minutes which should flush everything, including anything stuck at the DSLAM. :four_leaf_clover: :crossed_fingers:

Dr. Know - thanks for the link to Connected: An Internet Encyclopedia

Yes, have done factory reset, devices have been replaced by Wyze, and power down the router. I have not found any other spot to flush or delete in the Wyze phone. Note that I have had devices other than Wyze generate a correct IP address in the 192.168.1.x subnet so the modem is working as it should. Only the Wyze devices try to use the 192.168.4.x subnet.

What model of Wyze equipment are you installing?
They are really not smart enough to retain a subnet after power off and reset but the x.x.4.x subnet must be coming from somewhere. :man_shrugging:
Maybe something was stored on a uSD card

I am not doing the testing with a Wyze outlet since it is the simplest. It is a brand new outlet that Wyze sent me as a replacement to fix the issue. Wyze asked for the my devices back including the outlets because they said they wanted to test them. As far as I know, they never tested them just like I don’t think they ran smiffer software against the trace they had me run, nor can the support people or their second tier support people seem to be authorized to run a suggested set of tests that I suggested that would recreate the problem. I have asked to have this issue escalated but there does not seem to be a way and thus the title – need management help.

@dav2434890 - Wyze Ticket 988235 regarding Wyze Outlet product has been tagged for attention.

1 Like

Correction - all testing is with the Wyze outlet - old style

Well, I came charging in here but I’m also out of my depth here. I’m sorry that you’ve been running into this!

You mention specifically the original Wyze Plug later on but say that none of your Wyze devices work in the beginning. Could you please clarify which types of devices you have that are impacted?

1 Like

All of my devices are impacted. I was not able to define my pan-cam, my 2 outlets, and my bulb. Wyze replaced only the 2 outlets and the bulb because at the time I did not realize that my pan-cam also would not work. Since receiving the 3 devices I think I might have tested the bulb but if so I do not know if the IP subnet was the issue for this. I did all my other testing on only one of the outlets so the other one has never been used. After trying many things, I finally realized by looked at the details when it fails with no internet that the subnet IP was the problem. If you look at the many tickets you will see the suggest test that Wyze could easily do in about 15 minutes that I think would recreate my issue.

I’m sorry, I’m not one of the support folks and don’t really go in there. Part of why I don’t think I’ll be super helpful is that I can draw attention to tickets but that isn’t really the problem here. I was hoping to collect info to send over to one of the product team people to see if they have any ideas because an issue impacting multiple devices is surprising and not common. Generally, I’d be checking on firewall impact in a case like this but the language you’ve been using is over my experience level. :sweat_smile:

1 Like

I basically have two issues with Wyze.

  1. The support staff should not ask for information to review and then never reply as they say they will. I think on some of the calls that the support staff was in contact with the product support staff but they have run out of ideas.
  2. The probable software bug itself.

The probably software bug needs to be escalated to the support manager. He is the one to first read the many tickets and then direct people to run the suggested test which I think will create the same issue with only about 15 minutes of work without impacting your network. If it does not create the same issue, then something on my end is probably the cause but no one can think of where to look.

I personally think the issue results from how information is being saved to allow easy reconnects after a power failure or for after a device is deleted. My guess is that some code is being shared that should not be and that the code when a device is being deleted is missing deleting something.