I can't create a ticket no matter how I try

I’ve been using the app for a couple weeks with no problems so of course I bought more gear! But when I try to connect my Sense (bridge) the blue light comes on but isn’t recognized.

Of course I tried to submit a request. But when I go to that page I get a prompt to select a topic. Once I do so, nothing else happens. I tried with my phone and my tablet with the same results.

So I tried to submit via a web page. I got prompted to enter all the information and my contact data! Thought it was going to work., But when I hit “submit” it tells me that Captcha failed. There’s no Captcha challenge anywhere on the page. Tried two different computers, no luck,

Can anyone tell me where I might be going wrong?

In the app, tap on account > help & feedback > report an issue, fill it in then tap submit , then choose your email you want to send it with

1 Like

Got it. Did that, thank you. The email I got back (auto generated) suggests using Chat. I never found Chat on the app or website.

1 Like