How to get Band's Alexa function working again

I accidentally reset my band the other day when I only intended to reboot. To get the band working again, I had to re-pair with the Wyze app, but this somehow created a second Wyze band entry in my Alexa app and both show offline. I’ve tried disabling and re-enabling the Wyze skill in the Alexa app. I’ve tried shutting down the Wyze app and restarting it. I’ve closed the Alexa app and re-started it. No matter what I do, both Wyze band entries in Alexa show offline and the Alexa functionality on the band is gone.

It was working fine before I fumbled and reset it. (Well, it was more or less working fine. It would stop sending notifications on occasion, which was when I would just reboot it.)

Any suggestions are appreciated. I really love my Wyze band and would hate to replace it with a blockier looking watch.

When I lose Alexa functionality, I go to Band settings > Amazon Alexa (should say unauthorized?) > and sign in with my Amazon ID.

On your two entries, I guess you might try deleting both, then re-adding the Band after pressing Reset in the Band settings.


Strangely enough, even though I had already done the Amazon Alexa authorization, I tried–based on your suggestion about the authorization–un-authorizing it and re-authorizing it and that did the trick. Thank you so much!


PS: I figured out how to remove the offline Wyze band entry from the Alexa devices list. Just go into that entry and deregister it–the entry will go away.