How to fix "you're not on the same network" for downloading timelapses?

What happens if you disable mobile data on the phone?

1 Like

There are several characters that the Wyze firmware does not like. I discovered a long time when I tried to use my phone as a hotspot with the SSID of “Jim’s iPhone”. The Wyze cameras could not take the ’ . Changed my phone name to “Jims iPhone” and it worked fine.
With that said, the SSID that I normally use for all my IoT devices has both an underscore and a Hyphen in the name and it works fine. I am going to try a Time Lapse right now…

1 Like

Hi @lvader and welcome to the forum! :slightly_smiling_face:

Agree w/@Customer re: Mobile network. Couple more ideas:

  • Make sure the 5Ghz WiFi doesn’t have same SSID
  • Delete the cam from the App and re-install again.

Yes, it was prob. some change in one of the f/w updates.

1 Like

@Customer same error. I can see live view and playback, but no time lapse download.

1 Like

5ghz - currently it is connected to 2.4ghz only SSID “XYZ2”. 5Ghz is on separate SSID “XYZ5”. Phone connected to same “XYZ2”. Delete/reconfigure - that’s what I’ve done when I was switching between networks.

1 Like

Hi @lvader may have misunderstood your post or didn’t read title.
The Download from SD card is on the #wishlist

No, I’m not looking for direct download from SD card. I’m using in app Camera->Albums->Video.
It shows recorded timelapse, but trying to tap on it leads to “Connect to same wifi” pop-up message in the app. Previously that functionality worked (at least in May/June timeframe).

So the time lapses as far as I understand are stored on SD card. If you can pull up live views you don’t have a WiFi issue. I have never tried time lapses but this one sounds mysterious. Maybe a bug.

Oh wait, if your phone is perceived as being on a separate network then that would explain it.

1 Like

Yes, time lapse is recorded, stored properly on sd card (I checked content of SD card on computer), but app thinks that camera and phone on different wifi, even were it is not the case – they are on the same 2.4ghz access point.

Try to determine the IP addresses of both and see if they are on the same subnet (the “x” in 192.168.x.y). It sounds as if your router may be blocking something.

So this is another App on your phone, not the Wyze App? In that case (guessing), a hook used to access the stream may no longer be available in current Wyze release.

Once again: single dumb access point, same /24 net and addresses on both devices are from the same net. Single L2 network: communication between camera and phone is over wifi on the same wifi.
Router is separate device which is not involved in communication between those devices, only to outside world.

1 Like

It is official Wyze app. iOS, 2.16.25.

OK, I see. I’m able to view a video on my Android but haven’t tried a time-lapse as yet. Will have to try that. Hopefully someone with more knowledge will chime in with a solution.

I have same issue on my v2 and gave up. But I just got my v3 and still same issue. I never got time lapse to work or viewable from app or pc. Tried to record time lapse few different times, seem to be successful but when try to view, either says not on same network or file don’t exist.

I finally got my time lapse to work.

So in your case the message was completely accurate (your post says your cameras were on the guest network).

No not really accurate thats it say not on same network. I had set my WiFi on my phone to the same guest network as cam. But guest network limits protocol access that the app must look for to be consider same network. Hope you get what I mean.

1 Like

Oh no kidding. Thanks, I missed that reading the post.

So it seem that bottom line don’t connect any Wyze cam to guest network in thinking of keep your internal network safe from potential hack. Lol

PS, I run dual router setup for that.

1 Like