Cannot download a time lapse video

What am I doing wrong? I cannot download any video from this camera. All of my devices are on the same network (not the 5G one).


Your mobile device has to be able to directly see the camera on the WiFi. So if your phone is connected to the same Wifi SSID as the cameras, and it still does not work, it is possible your wifi router is set up with “Client Isolation” enabled. That is common in business environments, and in Hotels, less so in homes.

What type of wifi router do you have? Do you have any control over it?

If Chromecast works on the wireless, I would expect downloads to work. I do know that when connected to a dual band router with the same SSID on both bands (my phone connected with 5GHz and the Wyze cams connected to 2.4GHz), that I am able to download timelapse from the Wyze microSD to my Nexus 5X Android phone.

I do wish that the Wyze Cam Device info would show the current wifi ip address it obtained from the router’s DHCP server, and that there was a “test local” connectivity button you could verify with. But the message you are receiving is indicating that your phone is not able to communicate directly with the Wyze camera, and that is a requirement to download to your phone.

It’s a default Suddenlink router that I have no control over. I can use a chromecast without issue. I think I’ll just add another router and only allow 2.4Ghz and connect all Wyze devices to that…

Does the Suddenlink provided wifi router have more than one SSID (Wireless network name)? Are you sure your phone is connected to the same SSID that you entered when you setup the cameras?

Because you say that Chromecast works, it doen’t seem likely to me that wifi client isolation is active. Can you control the Chromecast with the phone you have the Wyze app loaded on?

It has the 2.4 and 5G SSIDs and none of my devices are connected to the 5G SSID. This is the SSID my camera is connected to… and my phone (where I’m attempting to download to)


On your phone (iPhone or Android), can you see more than one “Wifi Network” that starts with “suddenlink”? Is your phone connected to “”? It should be if you want to be able to download the timelapse. The other option you have is to take out the SD card, and load it onto a PC. it will be in the time_lapse folder and have .h264 (if I remember correctly) as the file “type”. You can view it with VLC (open source free media player that is very good).

If you have individual SSIDs for 5GHz an 2.4GHz, it is possible your Chromecast that is working is connected to the 5GHz radio (Chromecast 2nd gen support 2.4 & 5).

Did Suddenlink give you a password to log into the router? (May be printed on a label). If you are technically proficient, you can probably find some useful info there (like the DHCP leases).

Either you edited your last message, or I didn’t read it all before. I see you have answered the question about the phone.

So this is the phone with the Wyze app that you got the “can not download the video” message on? Is that the phone use used to set up the camera with?

I know at my house I am able to “ping” the cameras, but I know what IP address they are using from info in my router. It is possible that something in the router is blocking the traffic, but without more info I really can’t tell much.

This my require getting a log from the phone app and from the camera to be able to diagnose the cause.

From what you have shown, it seems that everything should work.

What is the (my guess is that it is a neighbor’s router due to the signal strength).

Yes, sorry I edited it to add photos.

I have a password for the router, but I can only view which is one of the reasons I’m considering dumping it and going back to a basic modem and my router. Since I can’t even see what’s connected I cannot determine the IP address associations. This phone is the phone I used to setup the devices.

The other networks are neighbors… and I’ll just pull out the SD card until I can change the network around here.

This is an older thread, but there’s a bug in the Android app that, I’m assuming, is caching the IP of the cam.

I just set all my cams to a reservation IP list, and found I couldn’t download any of the timelapse videos. The app was showing the wrong IP address, even after a force close and reboot.

I just cleared the cache and app data for the app (so, had to relogin) and it’s working again. Might help someone else. ?

I am having the same issue. Nothing has changed on my network and I can see that they are both on the same network. It worked before so I am not sure what has changed in a week. I have 3 cameras, 1 on 1 network and the other 2 on a different network. I had to change my phone to the appropriate network to download the time lapses last week and it worked fine but this morning none of the cams allow me to download the videos. Once again, nothing has changed on our network.

I just ran into a similar sounding issue on my wyze cam v2 running firmware Issue downloading a time lapse that is. Looking at the device info in the Wyze app, the local IP reported was After doing a network scan using an app on my phone, there was no device on my network assigned to that IP. I tried to ping that address and got no response. After logging into my router, my router reported that the IP address was actually, pinging that address was successful confirming that the Wyse Cam was definitely assigned that address. I can only assume that the IP changed at some point, but the app wasn’t given the new IP address, and therefore was unreachable locally. This sounds like a bug in either the App or the Wyze firmware.

The Solution:
In the end rebooting the camera using the app, then force quitting the app and re-opening it forced the IP address to update on the device info page. Downloading the time lapse was also successful after taking the above steps. Hope this is helpful for anybody experiencing similar issues. And hopefully they fix this issue in a future update so that this ceases to be an issue.

I was hoping this would resolve the same issue I am experiencing, but it did not. Since support did not provide a resolution I took some time to troubleshoot the issue. I moved the cameras to the guest network to isolate the cameras from the local network. Time lapse recording will not be download unless the guest network has the same permissions as the local network, which defeats the purpose of a guest network. Let’s see if the upcoming Maxdrive has a feature to allow downloads of time lapse recordings to other network besides the local one.

I scheduled a time lapse on one of my cameras and it seemed to run fine. Once it finished, I went to download it and the phone displayed the download timelapse icon (thumbnail with down arrow). When I clicked it, it downloaded a time lapse from a different day and different camera and never gave me an opportunity to download the one I wanted. I had to sneaker-net it off the camera.

In that case I would try clearing the app cache and force restart the app to see if it refreshes the links properly.

1 Like

I’ve done that with no luck. When I copied the file off the SD card, I didn’t erase it, not knowing if any dependencies existed. I guess I should try another time-lapse and see if any updates have changed things.

1 Like

this absolutely is the trick. Nothing had changed on my network and I know I was connected to the same network and couldn’t download a time lapse of me drilling a well. I got down to 50’ today and finally got the water I was hoping for and was excited to see the time lapse.

This trick got me working now and I’ll get the video on youtube shortly.

I just ran into this problem and after clearing the cache in the app, it worked perfectly.

Clearing cache worked for me as well. WYZE please fix this bug!

I’m having the same issue in the iOS app. Clearing cache or restarting camera didn’t resolve the issue.

1 Like