How can you make Wyze camera connect to Deco Mesh system

I just upgraded to a TPLink Deco Mesh system that work very well It has both 5G and 2.4G. But I can not see the different WiFi networks. Will Wyze pick the 2.4 G network? It doesn’t connect and I have no way to specify the 2.4 G network. Has anyone connected to the Deco Mesh WiFi and now do you tell Wyze to connect?
Thanks.

Welcome @kfreer

Did you set it up as one Mesh Network or did you setup a network for 2.4 and another for 5g? If you set it up as one, the devices should connect without issue. The only caveat is your phone will need to also be connected to your WiFi network.

If you set them up as different networks, then your SSID should show what you named each at.

Question though: Which Deco Mesh system are you using? I am asking as I had issues with streaming multiple devices through my Deco Mesh setup and found out that it is, or was, an issue with continuous streaming. It would simply hang during the stream. I used the Deco P7, X30, and X60. I agree that these are really nice devices and easy to use and setup, but they had this issue and I have since moved on. Now, they may have corrected the issue as others are using the TPLink setup.

2 Likes

Yes, I do. I use TP-Link. I rotate through different routers. My current is TP-Link. I’ve had many that the two frequencies were not separate. Some have been a problem. But TP-Link has not.

Do yourself a favor as we have said dozens of times here. Use the same SSID and password as you old one. It will reduce the chance of a problem.

2 Likes

Welcome to the Wyze User Community Forum @kfreer! :raising_hand_man:

If your new Deco Mesh uses the same SSID and Password as your old router when both bands are on the same network, the cams should automatically log into the 2.4GHz without issues. The cams only have a 2.4GHz antenna so that is the only band they can log into.

If you changed SSID or PW from the previous router, every device needs a new Setup routine run. Don’t delete them from the app, just run a new device setup. Even if your phone is on the 5GHz, it should still work. It has always worked for me on 3 different routers.

2 Likes

I have both Deco x86 and x50. The camera is probably trying to connect to x86. I had no options with Deco install. I know it is suposed to have 2 5G and 1 2.4G WiFis, but it never showed or identified the different channels. The camera just says it can not connect to the network. There may be nothing I can do to tell it how to find the 2.4G.

I did change the password during the set up, so maybe the Wyze camera is dead on the Deco network.

I think the camera did get deleted in the change over. I’ve been trying to test it as a new added camera, but the camera says it can not connect to the network. I think it is trying to connect to a Deco X86 network (i also have some X50s in the system). Thanks

If the cam was deleted, it will still be a new Setup anyway regardless of the new Password. All cams will need a new Setup if the WiFi password has changed. But there are some things you can do to help the setup:

  • Shut down all other networks
  • Disable 5GHz in the Router Settings
  • Disable your Mobile Data while installing to force the phone to only use the WiFi 2.4GHz.
  • Make sure Bluetooth, and Location GPS are also on.

Here’s a visual aid that may help. It’s from the X86 User Guide and depicts pages in an older version of the Deco app (substantially the same layout as the newest.)

If I understand correctly, you have a single network comprised of two different MODELS (X86 & X50) that are functionally compatible with each other.

1 Like

Here’s a trick worth knowing about. Since newer mesh or single node routers are combining 2.4 and 5 bands together AND if you have trouble, a trick is: keep an old regular pre-mesh pre-dated combined 2.4/5 router around the house to use to “get IoT devices” up on your network. Its sort of last resort, but it will work/help.

Think about it. Even if your new router has a different name and/or password, you can always drag out your old old backup router, and change its name and/or password to match what you are using on the new one. (You are only limited by your imagination.)

1 Like

:blush: Apologies. It’s kinda buried in the latest app:

More > Wi-Fi Settings > 2.4 GHz & 5 GHz Network > Advanced > Band

1 Like

Camera will not connect to wifi

I changed wifi network to tp deco mesh system. It has both 5 and 2.4G. But the camera will not pick up the 2.4G wifi and connect. It worked fine on my old Spectrum cable wifi. Any suggestions?

[Mod Note]: Your duplicate topic has been merged to conform to the Community Guidelines. Please avoid crossposting the same issue in multiple topics.

There seems to be an issue with the last security update causing some cameras not to see the Wifi name. Right now one of my ten cameras has this issue. That camera keeps saying it can’t find a network by that name. This is such a pain.

I’m using a TP Link Deco mesh system. Working without any trouble. But I’ve not had to add anything recently.

I would believe its an update to the app as many people are reporting. I’m sure it will be fixed soon with a fresh update to the app

And fixed “soon” for Wyze means several weeks. Not good when their software basically bricks a camera that is supposed to be for security.